■ユーザーズフォーラム リニューアルのお知らせ
新規投稿は新ユーザーズフォーラムにお願いします。

スマートurlの件

 

<前のページ |  1  |  2  

inoue > Re: スマートurlの件 @ 2012/12/20 10:44
お世話になります。
ロリポでのなんらか不具合ですね!
私もまだ解明してないんです。。。

でもって
とりあえずこれ確認してみてください。
以下はbaseCMSのデモ画面です。

http://demo.basercms.net/

でもってサイトマップにいってみてください!

サイトマップにホームまたはトップがないですよね?

だから
サーバーによっては無理なんではないかな?と
最近思うようになってきました。

自分で質問しといて、何の解決にもなってないですが・・・・
ryuring > Re: スマートurlの件 @ 2012/12/20 10:58
こんにちは。

サイトマップページはトップページを出力しない仕様だったりします ^^;

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

ryuring > Re: スマートurlの件 @ 2012/12/20 11:00
あ、ついでにいうと、

うちの会社のサイトはロリポップだったりします。
チカッパプランですがスマートURLはオンです。
http://www.e-catchup.jp/

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

masa77 > Re: スマートurlの件 @ 2012/12/20 17:39
ryuring さん inoueさん

ありがとうございます。 スマートURLはオフで運用することにします。

baseCMSのデモ画面です。
http://demo.basercms.net/

本当ですね。

http://demo.basercms.net/index
これも問題ないですね。

ryuring さん のページ 
各ページ php ではなくて html になっていますね。 
clothoweb > Re: スマートurlの件 @ 2012/12/21 17:39
ロリポップ - ロリポプラン

php.iniの設定ですがこの辺りは参考になりますでしょうか?
というか、うちのクライアントで確認してみたら

http://www.domain.com/index


とかでアクセスすると同じようにありませんって言われました。

けど、ryuringさんのサイトだと正常にトップが表示されますね。

ちなみに、私の環境の.htaccessはmasa77さんと同じ記述内容でした。

ひょっとすると.htaccess辺りに少し特殊な設定をしているとか。


masa77 > Re: スマートurlの件 @ 2012/12/22 11:08
clothoweb さん
ありがとうございます。

clothoweb さんの .htaccess の設定と少し違いますが
ロリポップ(ロリポ プランでした)さんの初期設定 と 
下記の変更箇所になっています

safe mode を OFF
mbstring.internal_encoding  UTF-8

clothoweb さんの設定と同じように変更しましたが
症状の改善はないです。
yuse > Re: スマートurlの件 @ 2012/12/25 23:00
こんにちわ。

直下にある.htaccessですが、

RewriteRule ^$ app/webroot/ [L]

RewriteRule (.*) app/webroot/$1 [L]

の間に下記1行を追加してみたらどうでしょうか?

RewriteCond $1 !^(index\.php)

↓こんな感じ
RewriteRule ^$ app/webroot/ [L]
RewriteCond $1 !^(index\.php)
RewriteRule (.*) app/webroot/$1 [L]
masa77 > Re: スマートurlの件 @ 2012/12/26 0:31
yuse さん

ありがとうございます。無事表示できました。\(^o^)/

 

<前のページ |  1  |  2  

ログイン
ユーザー名:
パスワード:


  新規登録 / パスワード紛失

検索

facebook
フォーラムで悩みが解決した場合など、よかったら「いいね!」をポチっとクリックしてください!質問の回答者や開発者の励みになります

フォーラムガイド


関連リンク

オンライン状況
40 人のユーザが現在オンラインです。 (39 人のユーザが フォーラム を参照しています。)

登録ユーザ: 0
ゲスト: 40