■ユーザーズフォーラム リニューアルのお知らせ
新規投稿は新ユーザーズフォーラムにお願いします。

スマートurlの件

 

<前のページ |  1  |  2  

masa77 > Re: スマートurlの件 @ 2012/12/19 19:57
サーバー名:ロリポップ

私も inoue さんと同じ症状です。

スマートURLはオンの状態でサイトマップからトップページをクリックすると
404 NOT FOUND
エラー : リクエストされたアドレス '/redirect:/app/webroot/index.php' はこのサーバにありませんでした。
となります。他のページは問題ありません。

試しに、別のレンタルサーバー(クロスサーバー)で同じテーマでテストしてみたところ
こちらは、問題なく表示しました。

サーバーの設定等の関係かと思い、ロリポップさんに問合せしたところ

baserCMSの開発元様に
ご確認いただくか、関連サイトをご活用下さいとの返事でした。
う〜ん。困りました。

どうもこの状態だと Google の検索で うまくページを拾ってくれないような感じです。
ryuring > Re: スマートurlの件 @ 2012/12/18 13:01
inoueさん、こんにちは。

safe_mode は off で全く問題ないです!

現在のサーバー上の状態がどうなっているかを次のページを参考に確認してみてはどうでしょうか?
手作業でスマートURLを設定する

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

inoue > Re: スマートurlの件 @ 2012/12/11 18:20
皆さんありがとうございます!

解決できなくとも感謝してます。

どうやらWAF設定じゃないみたいです!

今 現状私のサーバーロリポップはWAF設定は"無"になっており、

干渉してないみたいです。

ちなみにsafe_modeはoffですが、これは関係あるんでしょうか?
arata > Re: スマートurlの件 @ 2012/12/10 20:00
うひゃ〜!全然違った><; inoueさん、ごめんなさいごめんなさい!orz

goichiさん、回答ありがとうございますー!

これで解決すると良いですねー

■ 不明点解消できるかも。逆引きガイドもあります baserCMS公式wiki
■ Twitter:@arata

goichi > Re: スマートurlの件 @ 2012/12/8 17:41
引用:
サーバー側でなんとかっていう設定を無効に

たぶん、WAF機能ってやつじゃないでしょうか(^o^)

問題が解決するか分かりませんが
引用:
ロリポップのユーザー専用画面から
「WEBツール」→「WAF設定」へ進み、
設定を「無効」にする

という手順でこの機能をOFFにできるっぽいです。
(今回の問題に関係なかったらゴメンなさい!)
arata > Re: スマートurlの件 @ 2012/12/7 18:33
inoueさん、こんにちはー

ひょっとしたらこの辺が関係してるかもしれませんねー。。。(´ω`)
http://basercms.net/develop/archives/9

■ 不明点解消できるかも。逆引きガイドもあります baserCMS公式wiki
■ Twitter:@arata

ryuring > Re: スマートurlの件 @ 2012/12/7 1:45
こんばんは。

ちょっと前にどこかで見たのですが、ロリポップ!では、サーバー側でなんとかっていう設定を無効にしないといけなかったような。。。
それが関係しているかも・・・?
すみません、なんとかが思い出せないですΣ( ̄□ ̄‖)
中途半端な回答ですみません・・・

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

inoue > スマートurlの件 @ 2012/11/15 9:46
■ BaserCMSのバージョン:2.0.5.1
■ サーバー名:ロリポップ
■ 利用しているデータベース: MySQL
■ PHPスキル(自己評価): C
■ スマートurl:on

過去スレをみても、スマートurlの件で解らないところがありご質問させていただきます。
サーバーはロリポップでデフォルトで”BaserCMSのバージョン:2.0.5.1”をインストールしました。



スマートurlをonにしたところ、sitemap.htmlのトップページリンク(index)を押すと

sitemap.html
|-----------トップページ(index)
|
|-----------会社概要(about)
|
|-----------サービス(serice)
|
|-----------問い合わせ(contact)

[404 NOT FOUND
エラー : リクエストされたアドレス '/redirect:/app/webroot/index.php' はこのサーバにありませんでした。]

と表示されます。

スマートurlをoffにしたところ正常に元に戻り、クリックしたらトップ(index)ページに飛びます。

これはどうやって直せばよろしいでしょうか?

宜しくお願いします。




 

<前のページ |  1  |  2  

ログイン
ユーザー名:
パスワード:


  新規登録 / パスワード紛失

検索

facebook
フォーラムで悩みが解決した場合など、よかったら「いいね!」をポチっとクリックしてください!質問の回答者や開発者の励みになります

フォーラムガイド


関連リンク

オンライン状況
19 人のユーザが現在オンラインです。 (17 人のユーザが フォーラム を参照しています。)

登録ユーザ: 0
ゲスト: 19