キャッシュをクリアしたところ、HPの表示などが不正になった。
| SFCsaka > キャッシュをクリアしたところ、HPの表示などが不正になった。 @ 2013/4/8 16:32 |
|---|
|
Webサイトのメンテナンス時に
baserCMS:管理者画面のダッシュボード→システム設定→ユーティリティ→サーバキャッシュ削除 にてキャッシュクリアしたところ、 TOPページの表示がされなくなるという現象が発生いたしました。 index.phpが表示されず、無応答となっております。 管理者のログインも表示されておりません。 環境は以下の通りです。 ■ BaserCMSのバージョン:1.6.0 ■ レンタルサーバー名:NTTコミニュケーション Bizホスティング メール&ウェブ エコノミー ■ スマートURLの利用: OFF ■ 利用しているデータベース: mysql 5.0.67 ■ PHPスキル(自己評価): 全くわからない また、FTPのツールなどを利用して、手動でキャッシュを削除する方法などはございますでしょうか。 上記に関する情報をお持ちの方がおられるならば、情報をご提供いただければと思います。 どうぞ、よろしくお願いいたします。 ■ BaserCMSのVer:1.6.0 |
| ryuring > Re: キャッシュをクリアしたところ、HPの表示などが不正になった。 @ 2013/4/8 20:13 |
|---|
|
こんばんは。
FTPで接続して、app/config/install.php の debug 設定を 1 にしてから、ブラウザで再表示してみてください。 上記ファイルが見当たらない場合は、app/config/core.php で、debug の文字列を探してみてください。 Twitter:@ryuring |
| SFCsaka > Re: キャッシュをクリアしたところ、HPの表示などが不正になった。 @ 2013/4/9 10:34 |
|---|
|
ご回答ありがとうございます。
サーバキャッシュ削除 を押下後に、以下の作業を行いました。 app/config/install.php の中に debug 設定がなかった為 app/config/core.php の中の debug 設定を「1」に設定したところ 以下のエラーになりページが表示されませんでした。 Fatal error: Maximum execution time of 30 seconds exceeded in /usr/home/USERNAME/www/htdocs/cake/libs/folder.php on line 435 何らか他の方法があればご教示願えないでしょうか。 よろしくお願い致します。 ■ BaserCMSのVer:1.6.0 |
| SFCsaka > Re: キャッシュをクリアしたところ、HPの表示などが不正になった。 @ 2013/4/9 10:50 |
|---|
|
追加情報です。
動作しなくなったWebサイトをバックアップから戻し サイトが見れるようになった事を確認して、 app/config/core.php の中の debug 設定を「1」に設定したところ 全く同じ現象になり以下のエラーでページが表示されませんでした。 Fatal error: Maximum execution time of 30 seconds exceeded in /usr/home/USERNAME/www/htdocs/cake/libs/folder.php on line 435 以上です。 よろしくお願いいたします。 ■ BaserCMSのVer:1.6.0 |
| ryuring > Re: キャッシュをクリアしたところ、HPの表示などが不正になった。 @ 2013/4/14 22:23 |
|---|
|
こんばんは。追加情報ありがとうございます。
何を行うタイミングでエラーが発生するのでしょうか? フロント側のWebページを表示するタイミングでしょうか? 該当箇所のコードを見てみたところ、次のコードです。 再帰的な処理を行う為にディレクトリ構造を作り上げている処理だと思うのですが、 推測ですが、tmp フォルダ配下のフォルダを生成するタイミングではないかと考えております。 tmp フォルダ配下の現在のツリー構造を教えてもらえますか? もしかしたら、手動で、tmpフォルダ配下の構成を作ってあげたらなおるかもしれません。 Twitter:@ryuring |
| SFCsaka > Re: キャッシュをクリアしたところ、HPの表示などが不正になった。 @ 2013/4/15 10:40 |
|---|
|
こんにちは。
説明不足で申し訳ありません。 エラーになるのは、サイトのトップページをブラウザで表示する際に発生しておりました。 また、tmpフォルダ配下は以下の通りでした。 \htdocs\app\tmp \htdocs\app\tmp\backup\archives \htdocs\app\tmp\backup\database\mysql \htdocs\app\tmp\cache\models \htdocs\app\tmp\cache\persistent \htdocs\app\tmp\cache\views \htdocs\app\tmp\logs \htdocs\app\tmp\sessions このような内容で良いでしょうか? どうぞ、よろしくお願い致します。 ■ BaserCMSのVer:1.6.0 |
| oshita-sfc > Re: キャッシュをクリアしたところ、HPの表示などが不正になった。 @ 2013/8/6 17:05 |
|---|
|
以前こちらの方でSFCsakaが質問させて頂いた状況から変化無しの状態ですが、再度現象を確認したところ
baserCMS:管理者画面のダッシュボード→システム設定→ユーティリティ→サーバキャッシュ削除 ↓ app/tmp/cache 配下のファイルが削除前に比べ、全ファイル作成出来てない状態です。 /Model 4ファイル作成 /persistent 1ファイル作成 /view 作成されず 全ファイル作成出来てないため、ページが表示されないという状況だと思われます。 サーバキャッシュ削除の処理を行ったところで、再作成出来ないという現象があった方がいらっしゃいましたら、 解決方法等情報提供して頂けますでしょうか。よろしくお願いします。 ちなみに app/config/core.php を開きまして、キャッシュOFFの処理を行った場合も状況は同じです。 Configure::write('Cache.disable', true); Configure::write('Cache.check', false); よろしくお願いします。 環境は以下の通りです。 ■ BaserCMSのバージョン:1.6.0 ■ レンタルサーバー名:NTTコミニュケーション Bizホスティング メール&ウェブ エコノミー ■ スマートURLの利用: OFF ■ 利用しているデータベース: mysql 5.0.67 ■ PHPスキル(自己評価): 多少分かる程度 |
| oshita-sfc > Re: キャッシュをクリアしたところ、HPの表示などが不正になった。 @ 2013/8/7 11:42 |
|---|
|
ちなみにこの同一データをロリポップのレンタルサーバにインストールしたところ、その環境ではキャッシュクリアも問題なく動作しています。
レンタルサーバー:NTTコミニュケーション /www/htdocs の配下にインストール レンタルサーバー:ロリポップ / の配下にインストール インストール先によるパス名の変更等が必要ありますでしょうか? 他のサーバで同様の現象があった等の事例があればご教授頂きたいです。 |
| yuse > Re: キャッシュをクリアしたところ、HPの表示などが不正になった。 @ 2013/8/7 21:09 |
|---|
|
こんにちは
パスのところもくさいですが、、 まずは、PHPエラー的には、実行時間制限にひっかかってしまっているようなので cake\libs\folder.php の先頭あたりに、 set_time_limit(60); などを書き加えて実行時間を少し長くしてみてはどうでしょうか。 仮に、結果エラーでも、作成されるファイル数が前後で変わったら事象が少し進むので。 |
| oshita-sfc > Re: キャッシュをクリアしたところ、HPの表示などが不正になった。 @ 2013/8/8 9:13 |
|---|
|
yuse さん、こんにちは。
.htaccessあたりも怪しいんじゃないかなと疑ってますが。 まずはご指摘の点を修正して原因を探ってみたいと思います。 お忙しいところありがとうございました。 またよろしくお願いします。 |
| oshita-sfc > Re: キャッシュをクリアしたところ、HPの表示などが不正になった。 @ 2013/8/8 17:44 |
|---|
|
早速ご指摘頂いた点で、
set_time_limit(60); などを書き加えて実行時間を少し長くしてみましたが、状況は変わらずでした。 ちなみに90に変更した際も再作成されるキャッシュファイル数は変わらずでした。 .htaccessの記述間違い等であれば、1件もキャッシュファイルが作成されないんじゃないかと思われますがどうなんでしょう。 とりあえずNTTBizメール&ウェブ エコノミーにゲストアカウントを準備して貰い、現在のバージョンと同じBasercmsをインストールしてみて状況を確認してみたいと思います。 |
| oshita-sfc > Re: キャッシュをクリアしたところ、HPの表示などが不正になった。 @ 2013/8/12 14:37 |
|---|
|
色々と皆様にご指摘頂き、対処を重ねたところサーバキャッシュの問題は解決しました。
別アカウントにて再度Basercmsをインストールしたところ、特に問題なくサーバキャッシュが実行され、 再度本番環境にてBasercmsを再インストールしたところ、こちらもサーバキャッシュの再実行がうまくいきました。 結論としては、ソフト側には問題なく何かしらサーバ環境に問題があったと思われる結果でした。 お忙しいところ、皆様のご協力を頂き無事解決できましたのでお礼共々報告でした。 ありがとうございました。 |


