■ユーザーズフォーラム リニューアルのお知らせ
新規投稿は新ユーザーズフォーラムにお願いします。
このフォーラムは閲覧専用のアーカイブです。

Basic認証下でのフィード再認証について

nasca > Basic認証下でのフィード再認証について @ 2010/10/12 20:13
初めて投稿します。
Basic認証環境下でテストを実施しています。
認証した後に、WEB画面にフィードの一覧が表示されますが、
その一覧の項目をクリックすると再度認証が要求されます。
要求されないようにする方法を教えてください。
ちなみにフィードには、ログインIDとパスワードを指定して一覧表が出るようにしています。
よろしくお願いします。
BaseCMS1.5.9
non > Re: Basic認証下でのフィード再認証について @ 2010/10/12 20:19
こちらの記事の内容では解決できないでしょうか?

http://basercms.net/develop/archives/3
nasca > Re: Basic認証下でのフィード再認証について @ 2010/10/12 20:48
フィード設定画面のフィードURL欄に次のようにBasic認証のユーザー名とパスワードを埋め込みは、
すでにやっています。.htaccessについては、試していません。これを設定すればよいのでしょうか?
ryuring > Re: Basic認証下でのフィード再認証について @ 2010/10/12 21:01
こんばんは。

ちなみにフィードには、ログインIDとパスワードを指定して一覧表が出るようにしています。


この文面を見ると、意図的に2重に認証をかけておられるように見えます。

2重に認証をかけておられるのであればBasic認証の認証情報を保存するブラウザでない限り2回目の認証が出てしまうと思います。

また、フィード一覧のリンク先が別ドメインであれば、もちろん再認証となります。

もう少し具体的な情報を頂けないでしょうか?これだけは結論を出すのが難しいです。

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

nasca > Re: Basic認証下でのフィード再認証について @ 2010/10/12 21:24
説明がうまく出来なくて申し訳ありません。
まず、
本サイトは、外部から社員用に公開しようとしているサイトです。
社員が各々のユーザIDとパスワードにて認証するサイトとしています。

新たにBaserCMSを使用して公開画面を検討していますが、
当初、最初の認証画面でユーザIDとパスワード入力したあと、
INDEX画面のフィードの表示が「−」の状態でした。

そのため、このフォーラムの情報を入手し、
フィードのURLにユーザIDとパスワードを指定して、
やっとフィードの一覧表が表示されました。
(フィードは、別ドメインではありません。)

やりたいことは、認証は一度としたいのですが。。。
nasca > Re: Basic認証下でのフィード再認証について @ 2010/10/14 13:24
お世話になっております。
本件の状況がうまく伝わらないためと思い
状況説明の簡易資料を添付いたします。
この資料でご理解願います。

また、一点確認なのですが、
初期の認証で使用するユーザID/パスワードと
フィードのURLに設定するユーザID/パスワードが
同じであれば、一度目のユーザID/パスワードにて
以降の表示は、可能でしょうか?

これができれば、あとはセキュリティや運用面で問題があるかを
確認するのみとなります。
Book1.pdf
ryuring > Re: Basic認証下でのフィード再認証について @ 2010/10/14 14:23
こんにちは。

フィードの再認証ですが、同じ環境を再現しようと思ったのですが、再現できませんでした。

IE8を利用してBasic認証をかけている次のサイトにアクセスしたところ、
フィード読み込み部分をクリックしても再認証は求められません。
http://test.e-catchup.jp/6/
(ID:admin / PASS:demodemo でログインしてみてください。このサイトは確認して頂いたら削除します)

環境の問題でしょうか?

ちなみに、Basic認証の記述はどこの.htaccessに書かれているでしょうか?
上記のサイトは、baser フォルダ、cake フォルダと同階層の.htaccessに記述しています。

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

ryuring > Re: Basic認証下でのフィード再認証について @ 2010/10/14 14:26
追記です。

実際に読み込んでいるフィードは、

http://test.e-catchup.jp/6/news/index.rss

となります。

フィードの設定には、

http://admin:[email protected]/6/news/index.rss

と記述しています。

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

nasca > Re: Basic認証下でのフィード再認証について @ 2010/10/14 15:03
ryuring様

環境を作成していだだき感謝いたします。
確認させていただきました。
おっしゃるとおり、再認証の要求はされませんでした。

こちらの環境については、担当者に確認します。
少しお待ち願います。
nasca > Re: Basic認証下でのフィード再認証について @ 2010/10/14 19:18
こちらの環境がわかりましたので、連絡致します。

/etc/httpd/confの下のhttpd.confに設定しています。

設定内容は、下記内容となっています。

AuthUserFile /etc/httpd/conf/.htpasswd_info
AuthGroupFile /dev/null
AuthName "Please Enter UserId and Passward"
AuthType Basic
require valid-user
DirectoryIndex contact.htm board.cgi index.html index.php
# IndexIgnore *.*
# Options All
# AllowOverride All
# Options ExecCGI FollowSymLinks
# AddHandler cgi-script .cgi

これでわかりますでしょうか?

もう一点環境面での情報を連携します。
当初は、本データを作成するときには、infoディレクトリの下で作成しておりましたが
本番環境でBaserディレクトリ配下に変更しました。
ページやブログなど判る範囲でディレクトリ名を変更しましたが
ディレクトリ名が残っている可能性があり、そのディレクトリ名の違いで
再認証されることとなっているのかと想像します。
ryuring > Re: Basic認証下でのフィード再認証について @ 2010/10/14 19:40
こんばんは。

当初は、本データを作成するときには、infoディレクトリの下で作成しておりましたが
本番環境でBaserディレクトリ配下に変更しました。


DBの設定さえ変更すればフォルダ名の変更はあまり関係ないと思います。

httpd.conf で認証を設定されているという事ですが、ドキュメントルート直下の.htaccessに設定を移動してみてはどうでしょうか?

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

nasca > Re: Basic認証下でのフィード再認証について @ 2010/10/15 10:25
ryuring様

ドキュメントルート直下の.htaccessに設定を移動してみましたが、
再認証画面が表示されてしまいます。
困りました。もういちど、ブログなどで他のドメインや別フォルダを指していないか
調査します。

下記に、htaccessの内容を記載します。

satisfy any

AuthUserFile /etc/httpd/conf/.htpasswd_info
AuthGroupFile /dev/null
AuthName "Please enter your ID and password"
AuthType Basic

Limit GET POST
order deny,allow
deny from all
allow from 127.0.0.1
require valid-user
/Limit

IfModule mod_rewrite.c
RewriteEngine on
RewriteBase /baser/
RewriteRule ^$ app/webroot/ [L]
RewriteRule (.*) app/webroot/$1 [L]
/IfModule
ryuring > Re: Basic認証下でのフィード再認証について @ 2010/10/15 14:05
こんにちは。

Limit ディレクティブを外してみてはどうでしょう?

AuthUserFile /etc/httpd/conf/.htpasswd_info
AuthGroupFile /dev/null
AuthName "Please enter your ID and password"
AuthType Basic
require valid-user

<IfModule mod_rewrite.c>
    RewriteEngine  on
    RewriteBase    /baser/
    RewriteRule    ^$ app/webroot/    [L]
    RewriteRule    (.*) app/webroot/$1 [L]
</IfModule>


上記内容をそのまま利用してみてください。

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

nasca > Re: Basic認証下でのフィード再認証について @ 2010/10/19 10:35
ryuring様

ご教示ありがとうございます。
指定の通りに設定しましたが
結果は、残念ながら、前回と同様で1回目の認証では、終わらず、
再度、認証が発生します。。。
ryuring > Re: Basic認証下でのフィード再認証について @ 2010/10/19 11:02
こんにちは。

ブラウザを変えたり、端末を変えても症状は同じでしょうか?
サーバーに原因があるのか、クライアントに原因があるのかを特定したいです。

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

nasca > Re: Basic認証下でのフィード再認証について @ 2010/10/19 17:55
ryuring様

テストは、2名で行っています。
システム管理者(サーバー管理)がブラウザ(IEとFireFox)にて確認
小職が(IE6とFireFox3.6.10)にて確認。
双方とも最初の認証画面のほかにフィードをクリックすると2回目の認証画面がでます。
こちらの判断では、サーバーの環境と思われます。
BaserCMSの環境を再構築して作成しなおさないと無理でしょうか?
その際は、バージョンアップもすることが必要かと思われます。
ただし、いままでの費やした時間を考えるとやりたくはないです。
ryuring > Re: Basic認証下でのフィード再認証について @ 2010/10/21 3:14
こんばんは。

今回の件については、実環境を確認させて頂くのが一番早いと思います。
よろしければ、メール、電話等で対応させて頂きたいと思います。

多くの方が利用されるレンタルサーバーであれば無償でなんとか対応したいのですが、
独自サーバーという事であれば有償対応になりますのでご了承ください。

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

nasca > Re: Basic認証下でのフィード再認証について @ 2010/10/21 16:34
ryuring様

お世話になっております。
確かに、直接見ていただくのが
早いとはおもいます。
レンタルサーバーではないので有償かと。。。
有償ですと、いくらになりますか?
いくらかにもよりますが、予算が捻出できるかどうか。。。
ryuring > Re: Basic認証下でのフィード再認証について @ 2010/10/22 4:55
nasca さん

まずは、実環境を確認させてください。
多くの方に利用して頂きたいので、状況によっては無償でも構わないと思っています。
次の問い合わせフォームより、FTP情報、SSH情報を送ってみてください。
http://www.e-catchup.jp/contact/index

よろしくお願いします。

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

nasca > Re: Basic認証下でのフィード再認証について @ 2010/10/22 17:14
ryuring様

お世話になっております。
FTP情報、SSH情報をご要望とのことですが、
システム管理者に確認したところ、機密保護の関係上
外部公開を行うことはできないようです。
社内規定ですので、申し訳ありません。

なお、現在は、新たな環境を作成しテストを行う予定です。
サーバーの環境の問題と思いますので
こちらにて調査を継続していきます。
また、ご相談をさせてください。
ryuring > Re: Basic認証下でのフィード再認証について @ 2010/10/22 18:14
nasca さん

引用:
システム管理者に確認したところ、機密保護の関係上
外部公開を行うことはできないようです。
社内規定ですので、申し訳ありません。


当然の事です。
必要であれば、秘密保持契約を結ぶ事もできますので、どうにもならない場合はご相談ください。
(通常業務では必ず結んでいます)

フォーラム上で解決できる内容であればできるだけお力になりたいと思いますので、
またお気軽にご投稿ください。

力不足で申し訳ありません。
ご検討をお祈りします!

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

nasca > Re: Basic認証下でのフィード再認証について @ 2010/11/2 17:34
ryuring様
ご無沙汰しております。

サーバー環境を変更してみました。
現状では、FireFoxでは、
1度目の認証のみで、フィードの一覧をクリックしても
2度目の認証はなく、データを見ることができます。
ただし、
IEですと、フィードの一覧が表示できません。
設定画面からフィードの確認ボタンを押すと
無効な構文エラーとなります。
なにか原因がわかれば教えてください。
ryuring > Re: Basic認証下でのフィード再認証について @ 2010/11/2 22:01
nascaさん

利用されているIEのバージョンはいくつになりますか?

また、「確認」ボタンというのは正確にはどちらの確認ボタンでしょう?

1. フィード設定一覧の「確認」ボタン・・・フィードを読み込んで解析した上での記事のタイトル一覧が表示
2. 読込フィード一覧の「確認」ボタン・・・読み込み対象のRSSフィードを表示

無効な構文エラーという事ですが、実際のその画面のソースは表示できますか?
純粋に、xmlの構文エラーかもしれません。

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

nasca > Re: Basic認証下でのフィード再認証について @ 2010/11/5 13:12
ryuring様

説明が雑ですみません。

・利用されているIEのバージョンは
 →6.0
・「確認」ボタンは、
 →2. 読込フィード一覧の「確認」ボタン・・・読み込み対象のRSSフィードを表示
 です。
・無効な構文エラーという事ですが、実際のその画面のソースは表示できますか?
 純粋に、xmlの構文エラーかもしれません。
 →すみません。一覧がでないことに対しての画面すべてでしょうか?
  ちなみに1画面のみ下記に記載します。


 
<p>
	2010年10月の帰社日は<span style="color: rgb(255,0,0)"><strong>10月15日(金曜日)</strong></span>となります。</p>
<p>
	お間違えないようにお願いします。</p>
<p>
	当日は、下期全社総会(仮称)が開催されます。</p>
<p>
	14時から開始となりますので、みなさま遅れないようにしましょう。</p>
<p>
	場所は、労政会館 第5会議室です。</p>
<p>
	【交通費・その他領収書の精算】<br />
	 13:00までに精算をお願いします。<br />
	【本社の戸締り】<br />
	 13:45に本社の鍵を閉めます。<br />
	【勤務表の書き方】<br />
	 終業時間は17:30とします。<br />
	 作業内容欄には、下期全社総会(仮称)(※h)と記述<br />
	 ※時間数は各自で異なる<br />
	&nbsp;</p>

ryuring > Re: Basic認証下でのフィード再認証について @ 2010/11/5 16:08
こんにちは。

・無効な構文エラーという事ですが、実際のその画面のソースは表示できますか?
 純粋に、xmlの構文エラーかもしれません。
 →すみません。一覧がでないことに対しての画面すべてでしょうか?
  ちなみに1画面のみ下記に記載します。


こちらも説明不足ですいません。

「無効な構文エラー」というのが「どこに」、「どのように」表示されているかを確認したかったです。

「無効な構文エラー」というのが表示されているのをスクリーショットで撮って、ここに上げてもらえますか?

ちなみに、表示されるタイミングは、読込フィード一覧の「確認」ボタンをクリックしたタイミングという事で間違いないですよね?

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

nasca > Re: Basic認証下でのフィード再認証について @ 2010/11/5 16:18
ryuring様

了解しました。
資料を送ります。
ご対応お願いします。
BaserCMS構文エラー.xls
ryuring > Re: Basic認証下でのフィード再認証について @ 2010/11/5 19:36
nascaさん

IEではフィードの表示自体ができてないという事ですね。
で、ブラウザのタイトルバーに「無効な構文エラー」と表示されると。

URLを見ると、「index.rss」ようするに、フィード用の正常なURLが表示されているので、おそらく、フィードのXML構文エラーが原因だと思います。
ただ、通常は、エラーは発生しないので、おそらく、実際のブログ記事のデータがうまく処理できてないのだと思います。

上記URLを、Firefoxなど、正常に表示できるブラウザで表示し、ブラウザの「ソース閲覧機能」で表示したものを、テキストファイルとして保存し、ここに添付して頂けますでしょうか?

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

nasca > Re: Basic認証下でのフィード再認証について @ 2010/11/8 11:01
ryuring様

ご要望の資料を添付します。
お手数かけます。


index.zip
ryuring > Re: Basic認証下でのフィード再認証について @ 2010/11/9 2:17
nasca さん

データありがとうございます。
確認したところ、データは特に問題はないようです。

ただ、IE6で、読み込みフィード一覧の「確認」をクリックしたところ、こちらの環境でも「無効な構文エラー」の件を確認しました。
これは、読み込みフィードのURLにBasic認証を含んでいる為のようです。

しかし、その状況でも、サーバーサイドでは問題なく読み込めているようで、2度目の認証メッセージは表示されず再現する事ができません。
その他に環境上の原因があるのだと思います。

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

nasca > Re: Basic認証下でのフィード再認証について @ 2010/11/9 16:48
ryuring様

調査の程、ありがとうございます。
無効な構文エラーが原因ではないと言うことですね。
こちからもう1点確認させてください。
該当するフィードには、複数のブログを設定してあります。
これが問題となることはありますか?
1フィード1ブログであれば、表示されます。

添付ファイルに設定画面を貼り付けましたので
参考としてください。
フィードの設定.zip
ryuring > Re: Basic認証下でのフィード再認証について @ 2010/11/10 11:52
nascaさん

試しに一つのフィード設定に対し、3つのブログを設定してみたのですが、特に問題なく、再認証も入りませんでした。

動作確認は、IE6 / safari で行ないました。


引用:
1フィード1ブログであれば、表示されます。


複数の場合は、どうなるのでしょう?表示されない?エラー?
再認証が求められるかどうかのお話ではなかったのでしょうか?

記事が正常に公開ページに反映されるかどうかが問題という事であれば、
フィードは、表示速度高速化の為、3つのキャッシュを利用しています。
その3つをクリアしてください。
・システム設定のサーバーキャッシュを削除するを実行
・フィード管理のキャッシュを削除するを実行
・ブラウザのキャッシュを削除

また、フィード読み込み部分に次のコードを書く事で、AJAXでなくPHPでフィードを読み込ませる事ができます。
これも試してください。(BaserCMS 1.6.6以降)
<?php $baser->feed({フィードID}) ?>


ただ、1.6.6ではこれを行った場合、テストコードが混入しているようです。
次のURLを参考にソースコードを修正してください。

http://forum.basercms.net/modules/newbb/viewtopic.php?topic_id=167&forum=5

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

nasca > Re: Basic認証下でのフィード再認証について @ 2010/11/12 19:38
ryuring様

返信が遅くなり、すみません。
現状ですが、FireFoxですと、問題なくフィード一覧は、表示されます。
IE6.0は、フィード一覧が表示されないので確認できませんでしたが
ページでAJAXの指定で、http://ユーザID:パスワード@XXXの指定を削除したら、
フィード一覧が表示されました。

もう一度、現状を記載すると
        フィード一覧    認証
 FireFox   OK         2回要求される
 IE6.0    OKのようです。   2回要求される

まだまだ調べる必要があります。
ryuring > Re: Basic認証下でのフィード再認証について @ 2010/11/15 13:31
こちらの環境では全く再現できないのでなんとも言えないのですが、
ajaxではなくphpの関数で読み込ませた方がよいのではないでしょうか?

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

nasca > Re: Basic認証下でのフィード再認証について @ 2010/11/22 10:02
ryuring様

一週間ほど連絡をしていなくて、すみません。
現状の報告をします。

テスト環境では、
1.5.9から1.6.0のバージョンアップまでは、OKです。
PHPに修正してフィード一覧の表示および認証の件ですが、
FireFox、IE6.0双方でも
 フィード一覧表の表示OK。
 また、認証も初回のみで、フィード一覧での認証はないです。
これから、1.6.6までのバージョンアップと本番機の環境を整備します。

ちなみに、「1.5.9からのバージョンアップについて」の質問者が
うちのシステム管理者です。
あわせて、ご対応のほど、よろしく願います。
ryuring > Re: Basic認証下でのフィード再認証について @ 2010/11/23 17:28
こんばんわ。

引用:
FireFox、IE6.0双方でも
 フィード一覧表の表示OK。
 また、認証も初回のみで、フィード一覧での認証はないです。


結局、再認証は行われなくなったという認識でいいのでしょうか?

もし、そうであれば、原因をここに書いて頂けると、同じ事で悩まれている方の助けになりますので
よろしくお願いします。

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

nasca > Re: Basic認証下でのフィード再認証について @ 2010/11/25 21:25
ryuring様

>再認証は行われなくなったという認識でいいのでしょうか?
現状は、そうです。
ただし、テスト機の環境であり、本番機ではありません。
これからバージョンアップを行い、本番を同じ環境にしてテストをします。
この作業後に2度目の認証かくるかが、わかります。

なお、
環境であることは、間違いないのですが、
バージョンアップなどをしていますので
原因を特定することができるかどうか。。。
お約束はできませんが、原因がわかりましたら
記載させていただきます。
お世話になっているのに申し訳ありませんが
ご理解のほど、よろしくお願いします。