Strict Standards とページ上部に表示されて管理ページへのログインも出来ない。
| ddkk > Strict Standards とページ上部に表示されて管理ページへのログインも出来ない。 @ 2014/6/30 17:48 |
|---|
|
お忙しい中恐れいります。質問させてください。
ページ上部に下記のエラーが表示されてしまいます。 Strict Standards: Redefining already defined constructor for class Object in /hogehoge.jp/cake/libs/object.php on line 62 Strict Standards: Non-static method Configure::getInstance() should not be called statically in /hogehoge.jp/cake/bootstrap.php on line 46 Strict Standards: Non-static method Debugger::invoke() should not be called statically, assuming $this from incompatible context in /hogehoge.jp/cake/libs/debugger.php on line 566 Strict Standards: Non-static method Debugger::getInstance() should not be called statically, assuming $this from incompatible context in /hogehoge.jp/cake/libs/debugger.php on line 566 使用しているバージョンが「2.0.5.1」なのでそれが原因かと思いバージョンアップ前に管理画面からバックアップをしようと「/admin/users/login」からログインしようと試みましたが同様のエラー文&CSS切れ表示の画面となりログインも出来ません。 解決方法やヒントなどありませんでしょうか? 何卒ご教示下さいますようお願い申し上げます。 ■ BaserCMSのバージョン:2.0.5.1 ■ レンタルサーバー名:お名前ドットコムレンタルサーバー[PHP 5.5.8] ■ スマートURLの利用: [ON] ■ 設置フォルダ: [ドキュメントルート] ■ 利用しているデータベース: [CSV] ■ PHPスキル(自己評価): [ E ] |
| ddkk > Re: Strict Standards とページ上部に表示されて管理ページへのログインも出来ない。 @ 2014/6/30 18:49 |
|---|
|
>■ レンタルサーバー名:お名前ドットコムレンタルサーバー[PHP 5.5.8]
レンタルサーバーのコンパネでPHPバージョンを変更出来るようになっていたのでPHPを5.2.17へ変更したところ解決しました。 ログイン出来るようになったので、baserCMS 2.1.2までアップデートしました。 暫定的ではありますが解決済とします。 お騒がせしました。 |
| goichi > Re: Strict Standards とページ上部に表示されて管理ページへのログインも出来ない。 @ 2014/6/30 18:52 |
|---|
|
インストール後に何かしらのタイミングで、このような状態になったということで良いしょうか?
あと、PHP5.5というのが気になっています。 お使いのbaserCMSのバージョンだと、CakePHPのバージョンが1.2.xなので、PHP5.5環境ではそもそも上手く動かないのかも知れません。 CSVで運用中とのことなので、ローカル環境で再構築し、公式のリリースノートを参考に、順次バージョンを引き上げていき、3系統まで引き上げれば動くかもしれません。 私自身がPHP5.5環境で試したことがないので、間違っていたらすみませn。。。 |


