スマートURLをOFFにしたところ、ログインも再インストールも出来ない状況になりました
| yaketako > スマートURLをOFFにしたところ、ログインも再インストールも出来ない状況になりました @ 2015/1/21 13:44 |
|---|
|
はじめまして。
先日BaserCMSを導入させていただき、テスト運用も問題なく行っていたのですが、 管理画面で誤って「スマートURL」の設定をOFFに変更してしまったところ、以降ログイン出来ず、 新規インストールも出来ない状態になってしまいました。 インストールを試みた場合、インストール画面は出るのですがCSS、画像がリンク切れの状態で 表示され、そのままインストール開始すると、リダイレクトループの状態となり先に進むことが 出来ません。また、既設のものにログインしようとした場合も同様にループしてしまいます。 .htaccessでスマートURLをONにすることも試してみたのですが、結果は同じでした。 php.iniの設定かな?とも思ったのですが、ASJのサーバーはユーザーがphp.iniの設定を変更 することが出来ないようでして・・・ 解決策がなく困っております。ご教示いただけると幸いです。 ■ BaserCMSのバージョン:3.0.6.1 ■ レンタルサーバー名:ASJ ■ スマートURLの利用:OFF ■ 設置フォルダ: サブフォルダ ■ 利用しているデータベース:SQLite ■ PHPスキル:E |
| goichi > Re: スマートURLをOFFにしたところ、ログインも再インストールも出来ない状況になりました @ 2015/1/23 1:20 |
|---|
|
こんにちは(^^
もともとはONの状態で正常に動作していたのですよね? であれあば、手動で.htaccessを編集してONにすれば、元に戻るのではないかと思います。一度、試みていらっしゃると思いますので確認ですが、install.phpの状態はどうでしょうか? 書き換えを行われましたでしょうか? ONの状態で正常に動作していた環境であれば、とりあえず、もう一度元の状態(ONの状態)に戻す方向で作業を進めて頂くと、新しくインストールしなおすより安心な気がします。 お役にたてなかたっらすみません。参考までに投稿しておきます。 |
| yaketako > Re: スマートURLをOFFにしたところ、ログインも再インストールも出来ない状況になりました @ 2015/1/23 18:19 |
|---|
|
goichi様
ご返信ありがとうございます。 install.phpの書き換えも行ってみたのですが、結果は変わりませんでした。 おそらく、php.iniを編集出来れば解決する問題のような気がするのですが・・・ |
| n1215 > Re: スマートURLをOFFにしたところ、ログインも再インストールも出来ない状況になりました @ 2015/1/23 22:53 |
|---|
|
yaketako 様
以前はbaserCMSが同じサーバで正常に動いていたんですよね? ユーザ側でのphp.iniの変更ができないということは、 サービス側でphp.iniの設定変更やPHPのバージョン変更が行われていない限り、 以前とphp.iniの状態は全く変わっていないことになります。 php.iniの設定が変わっていないなら、goichiさんの仰る通り、baserCMSのファイルを以前の状態に戻すだけで動作するはずです。 (さらにリダイレクトループの症状からも.htaccesssが原因である可能性が高いと考えられます。) baserCMSのスマートURLの設定の実体は下記3つのファイルです。 * {baserCMSの設置ディレクトリ}/.htaccess * {baserCMSの設置ディレクトリ}/app/webroot/.htaccess * {baserCMSの設置ディレクトリ}/app/Config/install.php これらのファイルすべてがサーバ環境に応じて適切に設定されていなければ正常に動作しません。 ※もしファイルの中身を教えていただければ、正確なアドバイスがしやすいです。 サブディレクトリ設置ということでRewriteBaseに気をつける必要があります。 下記はbaserCMSの設置ディレクトリを「ドキュメントルート/subdir」、 トップページのURLをhttp://example.com/subdir/ とした場合の一般的な設定例です。 .htaccess app/webroot/.htaccess app/Config/install.php Twitter: @n_1215 |
| yaketako > Re: スマートURLをOFFにしたところ、ログインも再インストールも出来ない状況になりました @ 2015/1/24 17:41 |
|---|
|
n1215 様
詳細なご回答、誠にありがとうございました。 おっしゃる通り、ファイルを以前の状態に戻す形で進めたいのですが、前回書き込み後に一度設置したフォルダを 全て削除して再インストールを試みる、という操作を行ってしまったため、app/Config/install.phpが 存在していません。新規インストールをしたい場合、どうすればよいでしょうか? インストール画面で画像・CSSのリンクが外れていたことから、core.phpの書き換えを行い、 .htaccessをn1215様の記述を参考に書き換えてみところ、リンク切れは解消されないままで、インストールを 続行したところリダイレクトループの状態ではなくなり、404Not Foundの状態となりました。 ↓エラーメッセージ The requested URL /app/webroot/subdir/index.php was not found on this server. 上記の通り、webrootとindex.phpの間にsubdirのフォルダ名が挟まってしまっています。 もう一度設定を見なおしてみます…。 お手数をおかけして申し訳ございませんが、宜しくお願い致します。 |
| n1215 > Re: スマートURLをOFFにしたところ、ログインも再インストールも出来ない状況になりました @ 2015/1/24 20:07 |
|---|
|
すみません、RewriteBaseが間違っていたようで申し訳ないです。
これでいかがでしょう? app/webroot/.htaccess Twitter: @n_1215 |
| yaketako > Re: スマートURLをOFFにしたところ、ログインも再インストールも出来ない状況になりました @ 2015/1/26 15:01 |
|---|
|
n1215様
お世話になっております。教えていただいた通りに.htaccessの内容を書き換え、 再度インストールを試みたところ、正常にインストール画面が表示されました! ありがとうございました。ですが、また別の問題が発生してしまい、困っております。 インストールは通常通り進んだのですが、step5の時点で画面が真っ白になってしまい、 インストールが完了しませんでした。ただ、インストール完了通知メールは届いており、 設置フォルダにアクセスしてみたところ、ホーム画面は表示されているのですが、 以下のようなエラーメッセージが表示されます。 Not Found エラー: The request sent to the address '/subdir/app/webroot/index.php/subdir/' was invalid. また、管理画面にアクセスしようとした場合も同様にエラーメッセージが表示され、 ログインすることが出来ません。 加えて、ホームから新着情報ページにアクセスしたところCSS・画像が反映されず、 Not Found エラー: The request sent to the address '/subdir/app/webroot/index.php/news/subdir/app/webroot/index.php/news/' was invalid. とエラーメッセージが表示されます。 質問ばかりで大変申し訳ございませんが、解決方法を教えていただけると幸いです。 宜しくお願い致します。 |
| n1215 > Re: スマートURLをOFFにしたところ、ログインも再インストールも出来ない状況になりました @ 2015/1/26 15:32 |
|---|
|
まだ駄目でしたか……。
他に関連しそうな設定と言えば、install.phpの中の値くらいだと思うのですが。 BcEnv.siteUrlが正しいかどうか確認してみてください。 BcEnv.siteUrlの設定が問題ない場合、もしかするとBaseUrlを変更すると動くかもしれません。 Twitter: @n_1215 |
| yaketako > Re: スマートURLをOFFにしたところ、ログインも再インストールも出来ない状況になりました @ 2015/1/26 17:09 |
|---|
|
早速のご返信、ありがとうございました。
install.phpの設定、確かめてみたところBcEnv.siteUrlの値が /subdir/ではなく、/subdir/app/webroot/となっており、修正しましたが 状況変わりませんでした。同じく、BaseUrlの値も変更してみましたがこちらも 変わらず‥ もう少し色々と試してみます。もし他に思い当たる部分などありましたら、 教えていただけると嬉しいです。 |
| n1215 > Re: スマートURLをOFFにしたところ、ログインも再インストールも出来ない状況になりました @ 2015/1/26 17:42 |
|---|
|
install.phpファイルの正確な内容をSecurity.saltとSecurity.cipherSeedを省いて見せていただけませんか?
※BcEnv.siteUrlについてはhttp://example.com/subdir/ と仮のものに変更していただいて構いません。 Twitter: @n_1215 |
| yaketako > Re: スマートURLをOFFにしたところ、ログインも再インストールも出来ない状況になりました @ 2015/1/27 9:50 |
|---|
|
n1215様
大変お手数をお掛けして申し訳ございません。 現状のinstall.phpの内容は、以下の通りです。 Configure::write('Security.salt',(略) Configure::write('Security.cipherSeed',(略) Configure::write('Cache.disable', false); Configure::write('Cache.check', true); Configure::write('Session.save', 'session'); Configure::write('BcEnv.siteUrl', 'http://www.example.com/subdir/'); Configure::write('BcEnv.sslUrl', ''); Configure::write('BcApp.adminSsl', false); Configure::write('BcApp.mobile', false); Configure::write('BcApp.smartphone', false); Cache::config('default', array('engine' => 'File')); Configure::write('debug', 0); Configure::write('App.baseUrl', '/subdir/'); |
| yaketako > Re: スマートURLをOFFにしたところ、ログインも再インストールも出来ない状況になりました @ 2015/1/27 19:59 |
|---|
|
追記です。
install.phpをデバッグモードに設定してアクセスしてみたところ、 以下のようなエラーメッセージが発生していることを確認できました。 *****の部分はアクセスするURLによって変わり、例えばデフォルト画面から「ホーム」をクリックすると 「index.phpController が見つかりません。」となります。この時にURLが http://www.example.com/subdir/app/webroot/index.php/となっているため、 リダイレクトの問題が解消できていない?模様です。 何か手がかりを見つけたいですが・・・ 何卒宜しくお願い致します。 |
| n1215 > Re: スマートURLをOFFにしたところ、ログインも再インストールも出来ない状況になりました @ 2015/1/31 23:06 |
|---|
|
おまたせしています。
.htaccessとサーバ環境絡みだとbaserCMSのエラーはあまり参考にならないんですよね……。 ●設置ディレクトリのパスについて baserCMSの設置ディレクトリは {ドキュメントルート}/subdir で合ってますか? もしくは複数のサブドメインを利用できる環境で サブドメインがドキュメントルート以下のサブディレクトリに対応している状態だったりしますか? {ドキュメントルート}/{サブドメインのディレクトリ名}/subdir また、レンタルサーバの共用SSLのドメインに設置しているということはないでしょうか? 後者2つの場合、下記のRewriteBaseをさらに変更する必要があるかもしれません。 {baserCMSの設置ディレクトリ}/.htaccess {baserCMSの設置ディレクトリ}/app/webroot/.htaccess ●.htaccessの他の処理について また、レンタルサーバによっては.htaccessに他の処理が書かれていることもあります。 元々何か処理が書いてあってそれを上書きしてしまったということはないでしょうか? Twitter: @n_1215 |
| yaketako > Re: スマートURLをOFFにしたところ、ログインも再インストールも出来ない状況になりました @ 2015/2/13 15:39 |
|---|
|
n1215様
たいへん返信が遅くなりまして申し訳ございません。 教えていただいて方法、試してみたのですが解決には至りませんでした。 .htaccessの他の処理に関しても、上書きはしていないと思います。 取りあえず今回の案件については別のCMSを使用して構築することにいたしましたが、 入力画面の分かりやすさなどbaserCMSには捨てがたい魅力があります。また別の案件で 導入を検討したいと思います。ありがとうございました。 |


