■ユーザーズフォーラム リニューアルのお知らせ
新規投稿は新ユーザーズフォーラムにお願いします。
このフォーラムは閲覧専用のアーカイブです。

前のバージョンに戻す方法

kinka > 前のバージョンに戻す方法 @ 2016/7/22 16:53
レンタルサーバー名:ロリポップ
スマートURL: OFF
セーフモード:Off
データベース: MySQL
baserCMSバージョン: 3.0.8
CakePHPバージョン: 2.5.3
PHPスキル(自己評価): 新米


おせわになります。昨日3.0.8 から 3.0.10 へアップデートしました。


「最新パッケージを解凍して出来上がった lib/Baser/ フォルダをアップデート対象の同名フォルダに上書きします。」


公表どおりに最新Baserフォルダで旧Baserフォルダを上書きして、最後にアップデート実行をクリックすると、


ホームページはこんなふうになってしまいました。 ➜ http://kinwa3.boo.jp


どうか解決方法或いは前のバージョンに戻す方法をぜひお教えください。


よろしくお願いします。



−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−−

前のバージョン(3.0.8)に戻すには、

baser3.0.8をダウンロードして、3.0.8のbaser フォルダで 

上手く更新できなかったbaser フォルダを上書きする


という方法は正しいですか?



よろしくお願いします。


kinka > 前のバージョンに戻したいですが、 @ 2016/7/22 17:36
追加:

3.0.8 から 3.0.10 へアップデートの際に

気になるところがあります。

新バージョンは、

.../plugin/blog/config/data/default


dataの頭文字は小文字。

3.0.8の場合は、大文字です。


他に何箇所同じく /data/default/ の所で 大文字と小文字の違いがありました。



私は古いバージョンの大文字のままで、変更しなかったんですが、

これと関係ありますか?



よろしくお願いします。





goichi > Re: 前のバージョンに戻す方法 @ 2016/7/22 23:02
こんにちは。
引用:
「最新パッケージを解凍して出来上がった lib/Baser/ フォルダをアップデート対象の同名フォルダに上書きします。

ということですが、app/Config/core.phpは上書きしていますか? (アップデート方法のページ参照)

あと、拝見した感じだとCSSなどが正常に読み込まれていないようです。設置場所はサブディレクトリではありませんか?
その場合・・・

/.htaccess
/app/.htaccess
/app/webroot/.htaccess

の中身がどうなっているか、ここに中身を転記できるでしょうか?

引用:
前のバージョン(3.0.8)に戻すには、
baser3.0.8をダウンロードして、3.0.8のbaser フォルダで 
上手く更新できなかったbaser フォルダを上書きする
という方法は正しいですか?

一旦、待ったほうが良い気がします。ちょっと調べていませんが、DB構造が変わるなどしていると、予期しない問題が発生するかもしれません。このままバージョンアップを成功させたほうが、早い気がします。
kinka > Re: 前のバージョンに戻す方法 @ 2016/7/23 17:14
こんにちは。お世話になります。


1、 app/Config/core.phpは上書きしています.

2、 設置の場所はこんな感じです。

appフォルダ
libフォルダ
.htaccess
.travis.yml
composer.json
CONTRIBUTING.md
index.php
README.md
web.default.config

−−−−−−−−−−−−−−−

 /.htaccess
/app/.htaccess
/app/webroot/.htaccess

この三つの所も上書きする必要があるという意味ですか?


すみませんが、もう少し説明をお願いします。







goichi > Re: 前のバージョンに戻す方法 @ 2016/7/23 22:19
引用:
 /.htaccess
/app/.htaccess
/app/webroot/.htaccess

この三つの所も上書きする必要があるという意味ですか?

いえ、違います。(むしろ上書きされたのでおかしくなっている可能性もあります)

baserCMSの設置場所は、インストール先が「サブディレクトリなのかどうか」を伺いたかったのです。ここでいうサブディレクトリとは、例えば以下の様な場合です。

/home/sites/lolipop.jp/users/users・・・・・/web/sub_directry/

他のサーバーでもサブディレクトリに設置すると(独自ドメインであっても)、CSS等がはずれて今回と同じような現象が起きます。それを解消する為に、私は「.htaccessの中身を調整する必要があるのではないか」と思っています。

また、バージョンアップ前は、ver.3.0.8をスマートURL「OFF」のままで使用していらっしゃったようですが、ver.3.0.9あたりから、デフォルトで「ON」になりました。この辺りのことも問題の原因かもしれません。ちなみにスマートURLの機能も、.htaccessの中身と密接に関係しています。うまく設定が効いていないと、やはり今回のようにCSS等が外れてしまいます。
kinka > Re: 前のバージョンに戻す方法 @ 2016/7/24 9:37
大変お世話になります。


baserCMSの設置場所は、サブディレクトリではないと思います。


おっしゃったとおり、ver.3.0.8をスマートURL「OFF」のままで使用しています。


引用:「ver.3.0.9あたりから、デフォルトで「ON」になりました。」



このあたりの問題はどういうふうに修正してみればよろしいですか?


よろしくお願いします。
goichi > Re: 前のバージョンに戻す方法 @ 2016/7/24 11:27
引用:
このあたりの問題はどういうふうに修正してみればよろしいですか?

一旦、手動でスマートURLをOFFにしてみると良いかも知れません。↓公式サイトに参考になるページがありました。
http://basercms.net/manuals/3/base/4.html

.htaccessの中身にも簡単な解説が書いてあるはずです。そこを見てください。
kinka > Re: 前のバージョンに戻す方法 @ 2016/7/24 20:11
たいへんお世話になります。

3.0.8から 直接3.0.10へアップデートしました。3.0.8の場合、スマートURLがOFFになっています。 


/.htaccess に書いてある内容:

【スマートURLを手動でオフにする】
# ■ /.htaccess と、/app/webroot/.htaccess 内の、次の行で始まる行を全て削除します。
# RewriteEngine / RewriteBase / RewriteCond / RewriteRule
# ■ /app/Config/install.php の次の行を削除します。
# Configure::write('App.baseUrl', '');

上記の削除すべき内容は見当たらないです。


いまパソコンは、ログインできない状態となっています。


「Not Found

Error: The request sent to the address '/index.php/admin/admin/users/admin/admin/users/login' was invalid.」

という内容です。


原因が分からず困っています。ご指導よろしくお願いします。


goichi > Re: 前のバージョンに戻す方法 @ 2016/7/24 22:27
(もしも日本語の意味が分かりにくければ、別の表現にしますので、おっしゃってください)

引用:
原因が分からず困っています。ご指導よろしくお願いします。

エラーの内容から、ルーティングが上手く行っていないのだと思います。CSS等が外れてしまうことと、原因は同じだと思います。まず一番最初に思い浮かぶ解決策としては、一旦、このままスマートURLをONにして、ログインできるようにすることです。

その為には、3箇所ある.htaccessを編集しなければなりません。

/.htaccess
/app/.htaccess
/app/webroot/.htaccess

がそうです。また、スマートURLがONになると、いままでURLの中に入ってた「index.php」という部分は不要になります。例えば、ログイン画面も以下のように変わります。

旧)http://hogehoge.com/index.php/admin/login
新)http://hogehoge.com/admin/login

さて、ここから書く解決策で解決できるかどうか分かりませんので、作業前にバックアップを取るようにしてください。また、今までのやりとりで、「サブディレクトリではない」と教えてもらいましたので、そのことを前提で話を進めます(もしもインストール先がサブディレクトリであった場合、別の書き方になると思います)。

/.htaccess
まずはインストールディレクトリ直下にある.htaccessを以下のようにします。なければ作ってください。
RewriteEngine on
RewriteRule ^$ app/webroot/ [L]
RewriteRule (.*) app/webroot/$1 [L]


/app/.htaccess
次にappフォルダ内にある.htaccessを以下のようにします。既にそうなっている場合は、そのままで結構です。
Order allow,deny
Deny from all


/app/webroot/.htaccess
次にwebrootフォルダ内にある.htaccessを以下のようにします。
Allow from all
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ index.php [QSA,L]


続いてサーバー側に残っているキャッシュ(一時ファイル)を削除します。
/app/tmp/
この中にあるフォルダ「cache」「logs」「sessions」「schemas」を4つとも削除してください。

これからの作業が終わったら、サイトのトップページへアクセスしてください。この時、URLに「index.php」は必要ありません。
また、ログイン画面を確認してください。ログイン画面も上述の通り、「index.php」が不要になっています。

kinka > Re: 前のバージョンに戻す方法 @ 2016/7/25 10:37
大変お世話になりました。

こんなに長〜い、詳細で丁寧な解説を見て、まず感動しました。

自分が上手く言われた通りに操作できるかと心配しながら、やってみたら、


凄い!ホームページが開けた!


嬉しい気持ちでいっぱいです。


改めて感謝の意を込めてお礼を申し上げます。
goichi > Re: 前のバージョンに戻す方法 @ 2016/7/25 11:34
解決できて良かったです! お疲れ様でした! (^^)
kinka > Re: 前のバージョンに戻す方法 @ 2016/7/25 12:54
すみません、フロントのリンクが繋がらなくなったことに気づきました。

ファイルは
/app/webroot/theme/nada-icons/Elements/toppage


外部へのリンクが繋がらなくなりました。


今まではのリンクが下のような記述で正常に動きましたが、

−−−−−−−−−−−−−−−−−−−−−
$this->BcBaser->link(
$this->BcBaser->getImg('./icons_banner_l_03.png'),
'http://kinwa3.boo.jp/guoantj/guoantj.html',
array(
'target' => '_blank',
'class' => 'testLink'
)
);
?>

−−−−−−−−−−−−−−−−−−−−−


今クリックしたら、


「Error: The request sent to the address '/guoantj/guoantj.html' was invalid.」


が出ています。



よろしくお願いします。

kinka > Re: 前のバージョンに戻す方法 @ 2016/7/25 18:04
大変おせわになります。



インストール先がサブディレクトリの場合:例えば/aaa/lib/baser


もう一つのホームページをアップデートのところ、この前回の教訓を取って、一歩ずつ更新しようと思って、

まず 3.0.8 から 3.0.9へ、 それから3.0.9 から 3.0.10へと更新のつもりですが、


3.0.9のlib/baser ブォルダで、3.0.8の同名フォルダ /aaa/lib/baser を上書きしたあと、


「 http://{baserCMSの設置URL}/update」


上記のupdateの画面が出てきません。


[ Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at [email protected] to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.]

との内容です。


サブディレクトリの場合、どこを注意すればよろしいですか?




よろしくお願いします。




goichi > Re: 前のバージョンに戻す方法 @ 2016/7/25 18:53
引用:
http://kinwa3.boo.jp/guoantj/guoantj.html

ページそのものが無いような感じです。
一度、その固定ページが存在するかどうかを確認してください。
(たぶん、今までの問題とは別の原因だと思います。)
goichi > Re: 前のバージョンに戻す方法 @ 2016/7/25 18:55
スマートURLはどうなっていますか? もしも、3.0.8がOFFのままなら、アップデート前なので
http://{baserCMSの設置URL}/index.php/update
となるように思います。
kinka > Re: 前のバージョンに戻す方法 @ 2016/7/25 19:45
大変お世話になっております。

おっしゃったとおりに、このページは baserCMSの固定ページに存在しません。別に作ったページで、既にネットに転送しています。
今迄リンクで繋がっていたが、アップデート後にできなくなりました。


[ 引用:

ページそのものが無いような感じです。
一度、その固定ページが存在するかどうかを確認してください。]


php記述の問題ですか?


----------------------------------------------------


確かにスマートURLがOFFのままです。


[ http://{baserCMSの設置URL}/index.php/update ]


例えば:
http://(省略).../aaa/index.php/update  を入力したら、


「 Error: The request sent to the address '/aaa/index.php/update' was invalid. 」


が出ています。アップデートできません。


ご指導よろしくお願いします。



goichi > Re: 前のバージョンに戻す方法 @ 2016/7/26 9:46
引用:
別に作ったページで、既にネットに転送しています。


/app/webroot/guoantj/guoantj.html

guoantj.htmlの設置場所が、上のようになっていますでしょうか? 「webroot」配下が独自ドメインのドキュメントルートになります。

kinka > Re: 前のバージョンに戻す方法 @ 2016/7/26 10:16
大変お世話になります。


いいえ、guoantj.htmlの設置場所は、インストール先直下に置いています。


/guoantj/guoantj.html





webrootに置いたほうがいいでしょうか?
goichi > Re: 前のバージョンに戻す方法 @ 2016/7/26 11:17
引用:
webrootに置いたほうがいいでしょうか?

はい。webroot配下におかないと、意図したURLでは表示できません。
kinka > Re: 前のバージョンに戻す方法 @ 2016/7/26 15:47
凄い! おっしゃったとおりに操作したら、リンクが全部成功しました! 

goichi様のおかげで、難関がクリアできて大変有難うございます。



インストール先がサブディレクトリの場合の更新なんですが、

3.0.8から3.0.9へ進む最中、 lib/baser ブォルダで、3.0.8の同名フォルダ home/aaa/lib/baser を上書きしましたが、

その後のupdate画面が出ないです。「 Internal Server Error………… 」


baserCMSの設置はサブディレクトリaaaフォルダにあります。 home/aaa/lib/baser ………… 。

それとも.htaccessの編集が必要ですか?


ぜひご指導よろしくお願いします。
goichi > Re: 前のバージョンに戻す方法 @ 2016/7/26 22:42
引用:
それとも.htaccessの編集が必要ですか?

色々と考えたのですが、やはり編集が必要であろうと思っています。

以下、インストール先のサブディレクトリを「aaa」と仮定して進めていきます。本来のディレクトリ名に置き換えて読んでください。念のため作業前に既存の.htaccessのバックアップをとっておいてください。

/aaa/.htaccess
インストールフォルダ直下を前回と同じように編集します。.htaccessがなければ作ってください。
RewriteEngine on
RewriteBase /
RewriteRule ^$ app/webroot/ [L]
RewriteRule (.*) app/webroot/$1 [L]


/aaa/app/.htaccess
appフォルダの.htaccessを以下のように修正します。「aaa」という所は、本来のディレクトリ名で置き換えてください。
Order allow,deny
Deny from all

RewriteEngine on
RewriteBase /aaa/app
RewriteRule ^$ webroot/ [L]
RewriteRule (.*) webroot/$1 [L]


/aaa/app/webroot/.htaccess
最後にwebrootフォルダの中.htaccessを以下のように編集してみてください。
Allow from all
RewriteEngine on
RewriteBase /app/webroot
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ index.php [QSA,L]


これで、スマートURLがONの状態になります。お試しください。


kinka > Re: 前のバージョンに戻す方法 @ 2016/7/27 11:34
いろいろと大変お世話になりました。


goichi様のおかげで、全ての問題が解消しました。

そして 3.0.9 から 3.0.10へのアップデートも順調に終えました。


感謝、感謝の気持ちでいっぱいです(^^)