全くサーバーに関しては初心者です。お手柔らかにお願いします。
| mobobibi > 全くサーバーに関しては初心者です。お手柔らかにお願いします。 @ 2011/6/7 18:41 |
|---|
|
実は、BASERCMSを使いたい一身でドメインキングでサーバー取得、こちらにインストールしたいのですが、簡単インストールが無くて。。。。どうしてよいか全く分かりません。ダウンロードして、FTPをアップしてそれからどうすれば、インストール画面なるものはどうやって出せばよいのですか? そもそもup先も正解なのかなわかりません。
太変申し訳ありませんが、優しくご指導くださいませんでしょうか ■ BaserCMSのバージョン:1.6.11.4 ■ レンタルサーバー名:ドメインキング ■ スマートURLの利用: 何処で確認できますか? ■ 設置フォルダ: /httpsdocs/host ■ 利用しているデータベース 未使用?? ■ PHPスキル(自己評価): 全くわからない |
| ryuring > Re: 全くサーバーに関しては初心者です。お手柔らかにお願いします。 @ 2011/6/7 22:40 |
|---|
|
こんばんは。
一般的な「ドキュメントルート」にアップロードにし、 トップページにアクセスすればインストール開始画面が表示されるはずです。 ドキュメントルートとは、レンタルサーバーによって違いますが、 トップページを置く場所の事です。 そこに解凍してできた「フォルダの中身」を全てアップロードしてみてください。 Twitter:@ryuring |
| mobobibi > Re: 全くサーバーに関しては初心者です。お手柔らかにお願いします。 @ 2011/6/8 13:14 |
|---|
|
ありがとうございました。
すんなりインストール画面が出てきました。感動! しかしながらタイトル通りの無茶男ですので、インストール画面のSTEP1で早速行き詰りました。 下記基本必須条件でバツが出ました。そもそもフォルダの書き込み権限の変更の仕方が分かりません 。 下記項目の解消の仕方を教えて下さい。 --------------------------------------------------------------------------------- BaserCMSのインストール [ステップ2] インストール環境の条件をチェックしました。 次に進む為には、「基本必須条件」の赤いマークを全て解決する必要があります。 /app/config フォルダの書き込み権限(707 OR 777) 書き込み不可 /app/config フォルダに書き込み権限が必要です /app/config/core.php ファイルの書き込み権限(606 OR 666) 書き込み不可 /app/config/core.php ファイルに書き込み権限が必要です /app/tmp フォルダの書き込み権限(707 OR 777) 書き込み不可 /app/tmp フォルダに書き込み権限が必要です。 /app/webroot/themed フォルダの書き込み権限 書き込み不可 /app/webroot/themed フォルダに書き込み権限が必要です オプション ファイルデータベース データベースサーバーが利用できない場合には、SQLiteやCSVファイル等ファイルベースのデータベースを利用できます。 有効にするには、下記のフォルダへの書き込み権限が必要です /app/db/ の書き込み権限(707 OR 777) 書き込み不可 SQLite を利用するには、/app/db/sqlite フォルダに書き込み権限が必要です |
| ryuring > Re: 全くサーバーに関しては初心者です。お手柔らかにお願いします。 @ 2011/6/8 13:36 |
|---|
|
こんにちは。インストール画面が出てよかったです。
ただ、書き込み権限の件は、BaserCMSには関係ありませんので、「FTP 書き込み権限 変更」などでググってみましょう。 色々出てくると思いますよ。 Twitter:@ryuring |
| mobobibi > Re: 全くサーバーに関しては初心者です。お手柔らかにお願いします。 @ 2011/6/8 15:25 |
|---|
|
ありがとうございました!
ドメインキングのサーバーで設定完了しました。 完了までもうすぐでしょうか。 どきどきしますね。 そしてステップ2でエラーです。 度々すみません。 エラーの意味が分からないので教えていただけまでしょうか。 コチラもサーバーで設定になりますか? ★エラー内容 データベースへの接続でエラーが発生しました。データベース設定を見直してください。 mysql_connect() [function.mysql-connect]: Access denied for user 'iemoc''localhost' (using password: YES) ★設定内容 データベース設定 データベースサーバーの場合は、データベース情報を入力し次に進む前に接続テストを実行してください。 CSV以外の場合は、データベースが存在し中身が空である必要があります。 データベースタイプ MySQL PostgreSQL SQLite3 CSV データベースホスト名 ログイン情報 ユーザー名 パスワード データベース情報 プレフィックス データベース名 ポート ※ プレフィックスは英数字とアンダースコアの組み合わせとし末尾はアンダースコアにしてください。 ※ ホスト名、データベース名、ポートは実際の環境に合わせて書き換えてください。 |
| ryuring > Re: 全くサーバーに関しては初心者です。お手柔らかにお願いします。 @ 2011/6/8 15:35 |
|---|
|
こんにちは。
ドメインキングではMySQLが利用できたと思うのですが、事前にサーバーのコントロールパネルでの設定が必要なはずです。 「データベース」の種類とは、上から順に性能がよいという感じです。 ■ MySQL(サーバー設定必要) ■ SQLite(サーバー設定不要・環境によっては利用不可) ■ CSV(サーバー設定不要) サイトの規模が大きくないのであればSQLiteでも大丈夫です。そちらを選択しましょう。 Webページ、ブログ記事のそれぞれが100ページ以内であればCSVでも大丈夫です。 サイト規模が大きかったり複数人で同時に更新したりする場合は、MySQLがおすすめです。 レンタルサーバーのサポートなどわかる方に相談してみましょう。 Twitter:@ryuring |
| mobobibi > Re: 全くサーバーに関しては初心者です。お手柔らかにお願いします。 @ 2011/6/8 15:56 |
|---|
|
ドメインキングで設定したとおもいますが、下記のエラーで接続できませんでした。
エラーの解釈は? また対処方法をお教えねがえますのでしょうか。 よろしくお願いします。 データベースへの接続でエラーが発生しました。データベース設定を見直してください。 file_exists() [function.file-exists]: open_basedir restriction in effect. File(/var/www/vhosts/i-emoc.info/httpdocscss/font_small.css) is not within the allowed path(s): (/var/www/vhosts/i-emoc.info/httpdocs:/tmp) |
| ryuring > Re: 全くサーバーに関しては初心者です。お手柔らかにお願いします。 @ 2011/6/8 16:14 |
|---|
|
こんにちは。
エラー内容では判断できないです。 データベースは何を選択しましたか? MySQLの場合であれば、サーバーで設定された、ホスト名、ユーザー名、パスワード、DB名を入力しなければ接続に失敗します。 Twitter:@ryuring |
| ryuring > Re: 全くサーバーに関しては初心者です。お手柔らかにお願いします。 @ 2011/6/8 16:17 |
|---|
|
追記です。
インストールが中途半端な場合は、インストール画面の下の方にリセットする為のリンクが表示されているので、一旦リセットされた方がよいかと思います。 あと、言葉で伝えにくい内容の場合、画面のスクリーンショット等を貼り付けてもらった方が解決早いと思います。 Twitter:@ryuring |
| mobobibi > Re: 全くサーバーに関しては初心者です。お手柔らかにお願いします。 @ 2011/6/8 16:23 |
|---|
|
ありがとうございます。
やってみます。 エラー表示はされてますが、次へをクリックしたらインストール完了まで漕ぎ着けました。 初心者相手にご丁寧にすみませんでした。 いよいよCMS体験です。 これからもすごく大変なのでしょうね。 今後ともよろしくお願いします。 |
| mobobibi > Re: 全くサーバーに関しては初心者です。お手柔らかにお願いします。 @ 2011/6/8 16:24 |
|---|
|
ご丁寧にご指導ありがとうございました。
|
| mobobibi > Re: 全くサーバーに関しては初心者です。お手柔らかにお願いします。 @ 2011/8/22 12:29 |
|---|
|
1.シンプルコーポレートテーマをアップロードし適用しました。INDEXページは公開できるのですが、他のページについては公開ボタンをチェックして更新しても公開されません。
2.INDEXページを記事の入力して保存したのですが実際に保存されてなく、WEBに表示しません。 そもそもテーマーの使用になにかルールがあるのでしょうか? 手順を分かりやすくおしえてください! 現在編集中のサイトです ↓ www.susamagi.info |
| mobobibi > Re: 全くサーバーに関しては初心者です。お手柔らかにお願いします。 @ 2011/8/22 13:29 |
|---|
|
先ほど質問は、書き込み権限の問題です!
権限を書き込み可にしておく必要のあるホルダーはどれでしょうか? それと、トップページの画像した右サイド↓はどうやって編集するのでしょうか? ABOUT US 説明が入ります。説明が入ります。説明が入ります。説明が入ります。説明が入ります。 説明が入ります。説明が入ります。説明が入ります。説明が入ります。説明が入ります。説明が入ります。 説明が入ります。説明が入ります。説明が入ります。説明が入ります。 |
| ryuring > Re: 全くサーバーに関しては初心者です。お手柔らかにお願いします。 @ 2011/8/23 2:32 |
|---|
|
こんばんは。
書き込み権限のフォルダは、インストール時にチェックされるはずですが、チェックが正常動作してなかったということでしょうか? どちらのレンタルサーバーをご利用ですか? ABOUT US の部分の編集は、 テーマ管理で編集することもできますし、FTPを利用して編集することもできます。 テーマ管理から編集する場合、 「システム設定」 → 左サイドメニューの「テーマ管理」 → 対象テーマの「管理」と辿り、 レイアウトテンプレート一覧に、default.ctp というファイルが表示されていると思いますので、「編集」をクリックして編集します。 --- できれば、みなさんのよい情報源となるよう、一つのトピックに1つの質問でお願いいたします。 Twitter:@ryuring |


