■ユーザーズフォーラム リニューアルのお知らせ
新規投稿は新ユーザーズフォーラムにお願いします。
このフォーラムは閲覧専用のアーカイブです。

フィードを登録すると /feed/ajax/1.js で以下の Script Error が表示されます。

4260 > フィードを登録すると /feed/ajax/1.js で以下の Script Error が表示されます。 @ 2012/2/2 14:56
フィードを登録すると /feed/ajax/1.js で以下の Script Error が表示されます。

The script did not produce proper HTTP headers. Please see the error log to see the detail of the errors. Depending on the server configuration, you can also run thisscript under CGIWrap debugging. Usually, either rename or linkthe script temporarily to a file which ends with .phpdextension, or add a AddType application/x-httpd-phpcgi-debug .phpline to your .htaccess file.

セーフモードの関係の様な気がしますが、解決方法が見つかりません。

キャッシュを手動で削除しても、管理画面から削除しても表示されません。
しかし、数時間するとフィードは表示されるようになるので、キャッシュの問題の様な気もしないでもないですが・・・

解決策がございましたらご教授いただければと思います。
よろしくお願いいたします。

環境
baserCMSバージョン: 1.7.0 beta

CORESERAVER
CPU:Xeon L3360 2.83GHz x 4
Memory:8181MB
Apache:1.3系
PHP:5.2.5
MySQL:5.1.22

■ BaserCMSのバージョン:3.0.6.1
■ レンタルサーバー名:
■ スマートURLの利用: ON
■ 設置フォルダ: ドキュメントルート
■ 利用しているデータベース: PostgreSQL
■ PHPスキル: D

4260 > Re: フィードを登録すると /feed/ajax/1.js で以下の Script Error が表示されます。 @ 2012/2/2 17:11
わかりました。
ブラウザのキャッシュが原因でした。

フィードを新たに登録すると、ブラウザのキャッシュをクリアにしないとスクリプトエラーが起きてしまいます。
Firefox と Google Chorme で確認しました。

■ BaserCMSのバージョン:3.0.6.1
■ レンタルサーバー名:
■ スマートURLの利用: ON
■ 設置フォルダ: ドキュメントルート
■ 利用しているデータベース: PostgreSQL
■ PHPスキル: D

ryuring > Re: フィードを登録すると /feed/ajax/1.js で以下の Script Error が表示されます。 @ 2012/2/6 15:07
こんにちは。

ちょっとだけ調べたところ、PHPのCGIモードに依存する問題のようですね。

念の為確認なのですが、
ブラウザのキャッシュが問題だったという事は、「既にキャッシュをブラウザに保存している」という事ですよね?
「新しいフィード設定を作成した際」にエラーが表示されてしまうというのは何故でしょう?

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

4260 > Re: フィードを登録すると /feed/ajax/1.js で以下の Script Error が表示されます。 @ 2012/2/9 10:37
お世話になります。
CGIモードが原因なんですね・・・
CORESERVER では、現状フィードは使用できないんですね。。。
残念!

> ブラウザのキャッシュが問題だったという事は、「既にキャッシュをブラウザに保存している」という事ですよね?
> 「新しいフィード設定を作成した際」にエラーが表示されてしまうというのは何故でしょう?

更新前のキャッシュがブラウザに残っていて、更新後に更新前のキャッシュが何か影響を与えているのではないかと推測しています。
なので、更新前のキャッシュがなくなったら、更新後のフィードが表示できるのではないでしょうか?

私のレベルでは、この程度の「推測」しかできませんでした。
よろしくお願いいたします。

■ BaserCMSのバージョン:3.0.6.1
■ レンタルサーバー名:
■ スマートURLの利用: ON
■ 設置フォルダ: ドキュメントルート
■ 利用しているデータベース: PostgreSQL
■ PHPスキル: D