Ecologyテーマを利用させていただいております。
| keiji > Ecologyテーマを利用させていただいております。 @ 2012/7/11 10:43 |
|---|
|
Ecologyテーマを利用させていただいております。
大変気に入っているのですが、いろいろむずかしくて、ご教授いただけましたら幸いです。 プラグインに関してですが、どうしてもtwitterを入れるとレイアウトが崩れてしまったり、 管理画面が表示されなくなってしまいます。 また、facebookもウジットエリアに装着できないのです。 バージョン違いでしょうか? BaserCMSは2.0.0です。 twitterは2.0.0 facebookは1.1.1です。 ■ PHPスキル(自己評価): [ E ] お願いします。 |
| clothoweb > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/11 15:38 |
|---|
|
keijiさん、こんにちは!
引用: プラグインに関してですが、どうしてもtwitterを入れるとレイアウトが崩れてしまったり、 ごめんなさい、TwitterもFacebookもデフォルトの埋め込みタグを 使ってばかりいたので全然確認が出来ていませんでした!m(__)m これから動作確認してみたいと思いますので暫くお待ち下さいね。 ※ forumのsession切れで書いていた内容全部消えたので簡単な内容ですいません。 |
| arata > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/11 23:15 |
|---|
|
keijiさん、こんにちは!
facebook は・・・fb_likebox プラグインでしょうか?(違ったらごめんなさい だとしたら、以下のURLの zipボタン から、2系に対応しているバージョンを落として使ってみてください丶(・ω・)ノ https://github.com/materializing/fb_likebox ■ 不明点解消できるかも。逆引きガイドもあります baserCMS公式wiki |
| clothoweb > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/11 23:17 |
|---|
|
keijiさん、こんばんは!
やっと仕事が終わって今帰ってまいりました。^^; まだ途中ではありますが、経過報告をしておきたいと思います。 ・Twitterプラグイン ダウンロード→解凍→パーミッション変更→管理画面でインストール→ ウィジェットエリア管理にてドラッグ配置→ページ確認まで完了しました。 CSSに何も記述を入れていなかったので、こちらは後ほど公開してみます。 http://clothoweb.dip.jp/bc21/ ※ 目の保養の為、美女Linuxの下に配置してあります。笑 ・Facebookプラグイン ダウンロード→解凍→パーミッション変更→管理画面でインストール→ ウィジェットエリア管理にてドラッグ配置→「ん?」→リトライ→ 「んっ!?」→原因を探ってみる→すると下のようなエラーが表示されました。 テーマと同じようにindex.ctpを書き換えれば良いのかな?と思い変更後、 というところでこれからソースを調べてみるところに至っています。 大変お手数をおかけしますがもう暫く、お待ち下さいね・・・。 |
| clothoweb > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/11 23:30 |
|---|
|
keijiさん、こんばんは!
原因が分かりましたので報告いたしますね。 エラーを追いかけて全部手動で変更してみてたんですが、 開発者様のページに2.0対応版を配布されているのに今頃気づきました!笑 https://github.com/materializing/fb_likebox ※「Clone in Windows」ボタンの右の「ZIP」で落とせます。 引用: ※ 先生、公式のダウンロードページでの2.0対応版の追加をお願いします〜。 |
| arata > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/13 1:24 |
|---|
|
keijiさん、如何でしたでしょうか?解決してると良いんですが・・・(・ω・)
>> clothowebさん すいません!ご連絡ありがとうございますー 。・゚・(*ノω`*)・゚・ 追加して貰いましたー! http://basercms.net/plugins/archives/3 ■ 不明点解消できるかも。逆引きガイドもあります baserCMS公式wiki |
| keiji > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/13 2:11 |
|---|
|
ご回答いただきまして本当にありがとうございます。
いろいろやってみましたが、twitter,focebook ともにバージョンのあったものを入れても設置するとだめでした。 以下のようなコメントとレイアウトがくずれてしまいます。 CakePHP: PHP Rapid Development (高速開発)フレームワーク 見つかりませんでした。 エラー: リクエストされたアドレス '/fb_likebox/fb_likebox/get_fb_likebox' はこのサーバにありませんでした。 そしてさらにuploarderも使用しようとするとエラーになってしまいます。 パーミッションもすべて直したのですが・・・。 ん〜、むずかしいっす。 サーバーのSAFETY MODEがONのままだからでしょうか? すいません。 アコーディオンとか、シンプルとかは何度か使わせていただいてるんですが、今回はてこずってます。 FIRE BUG お教えいただきましてありがとうございます。 BASERCMSバージョン:2.0.0 レンタルサーバー:WAPPY |
| keiji > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/15 17:43 |
|---|
|
ご回答いただきまして本当にありがとうございます。
いろいろやってみましたが、twitter,focebook ともにバージョンのあったものを入れても設置するとだめでした。 以下のようなコメントとレイアウトがくずれてしまいます。 CakePHP: PHP Rapid Development (高速開発)フレームワーク 見つかりませんでした。 エラー: リクエストされたアドレス '/fb_likebox/fb_likebox/get_fb_likebox' はこのサーバにありませんでした。 そしてさらにuploarderも使用しようとするとエラーになってしまいます。 パーミッションもすべて直したのですが・・・。 ん〜、むずかしいっす。 サーバーのSAFETY MODEがONのままだからでしょうか?⇒レンタルサーバーに聞いたところ、phpのsefe modeはoffでした。 phpのバージョンが駄目なのでしょうか? すいません。 baserCMSのバージョンが1で、アコーディオンとか、シンプルとかは何度か使わせていただいてるんですが、今回はてこずってます。 FIRE BUG お教えいただきましてありがとうございます。 BASERCMSバージョン:2.0.0 レンタルサーバー:WAPPY |
| clothoweb > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/16 3:43 |
|---|
|
keijiさん、こんばんは。
以下のURIで動作確認用のサーバーを用意してみました。 http://clothoweb.info/~keiji/ Apacheはバージョン2.2.22でmod_rewriteなど利用可能です。>スマートURLON PHPはバージョンが5.2.17で、拡張モジュールは殆ど揃えてあります。 MySQLは5.1.58をインストールしています。 OSはCentOS5.8ですが、バックアップ専用機のためスペックは低いです。 一応、一般的な共用タイプのレンタルサーバー向けに構築しており 大抵の事が実現できるようにカスタマイズしているはいるのですが、 keijiさんのご利用環境と多少相違点があるかもしれません。 ですが、プラグインの設置状況や正常動作へ向けて少しでも 改善に向けての参考になればと思い設置してみました。 FTPや管理画面のログイン情報やMySQLデータベース情報などを PMにて送付しましたので、このフォーラムへログイン後に確認してみて下さいね。 PM=このフォーラム(xoops)の左側に表示される以下の部分 ------------------------ ユーザメニューアカウント情報 アカウント編集 イベント通知機能 ログアウト 受信箱 ------------------------ 一番下の「受信箱」の文字が赤色の太文字になっているかと思います。 「受信箱(1)」だったかと。 そちらをクリックしてみていただけるとメッセージが読めるはずですので〜。 |
| clothoweb > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/16 4:17 |
|---|
|
追記:
以下の情報を見るとPHPのバージョンは5.1.6みたいですね。 http://www.wappy.ne.jp/support/faq/server.html#q6 私が所有していてネットワークに接続しているサーバーの中には 現状ではPHP5.2.17以前のサーバーがありませんでした。 どなたか、同じバージョンで利用されている方は居られますか? |
| keiji > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/16 13:26 |
|---|
|
clothowebさん
お世話になっています。いろいろとありがとうございます。 WAPPYのphpのバージョンが低いのが原因でしょうか?サーバー変更をするか、BaserCMSを以前のバージョンに変えるかになりますでしょうか? clothowebさんのEcologyテーマが大変気に入ったのですが。 本当にいろいろありがとうございました。 |
| arata > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/16 14:05 |
|---|
|
WAPPYにお試し期間があれば、ちょっと登録して稼働テストを・・・と思ったんですがないみたいでションボリでございます(´・ω・`)
baserを1系からお使いだった、という事なので、2系にバージョンアップで利用されてますか? baserフォルダやapp配下のビュー・ファイル(ctp)が残ってたりしませんか? もし、ctpファイルが残ってたら、それらを削除しちゃって、プラグインを入れ直してみると良いかもです。。。 ■ 不明点解消できるかも。逆引きガイドもあります baserCMS公式wiki |
| keiji > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/16 16:23 |
|---|
|
ありがとうございます。
実は、wappyのサーバーで、2件のHPを1系で作成しておりまして、現在稼働中でございます。 そして、もう1件HPを知人に頼まれたのですが、そちらに2系でEcologyで作成中でございました。 なので、最初から2系をwappyにインストールいたしまして、今回のプラグインが動作できない phpバージョンであるということになったわけでした。 結構お安いサーバーでしたのでよいかなと思いましたが、更新など遅れていたのですね・・・。 まだロリポップとかの方が良かったでしょうか(苦笑) |
| clothoweb > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/16 18:23 |
|---|
|
keijiさん、こんにちは。
さすがにPHP4.3.9と4.4.2ではインストールのStep3辺りで こけてしまいましたが、5.1.6では何とか正常に導入できました。 以下、エックスサーバーですがPHP5.1.6で試してみた状況です。 http://www.kaigo-kaisyu.com/ 実際に、phpinfo()を以下で確認できます。 http://www.kaigo-kaisyu.com/info.php 管理画面内にある「プラグイン管理」では、左側に プラグインの数が「6つ」表示されていて、さらに右側三列目の 「バージョン」の列にはそれぞれ「2.0.0」と表示されていますよね? う〜ん・・・。それを考えるとやはり他の原因があるような 気がするのですが、各種サーバー会社毎の「パーミッション設定」か 「.htaccessの記述内容」、もしくは「アップロード先ディレクトリ」 そのどれか辺りが起因しているような気もします・・・。^^; ちなみに、仕事上かなりの手間が増えてしまうのでPHP5.3より 上位のバージョンでは試していませんのであしからず・・・。笑 Googleの検索で「wappy basercms」でバージョン1.6.15を 導入されている方は居られたのですがまだ2系では見当たらないですね。 それもあって「basercms本体+Ecologyテーマ+3種プラグイン」を セットにした物を用意してみました。(上記の5.1.6と同じ環境状態です) SQL構文はいじっていないので、テーマとプラグインはお手数ですが それぞれ手動でインストール設定をしていただきますようお願いします。 よろしければ一度、お時間のある時に試してみていただけますでしょうか。 5.46MBあるので添付ファイルでアップロード出来ない・・・。^^; というわけで以下のURIよりダウンロードする事が出来ると思います。 http://www.kaigo-kaisyu.com/basercms_2.0.0_plugin_packages.zip |
| keiji > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/17 11:51 |
|---|
|
clothowebさん。
いつも本当にお世話になっています。 インストールは問題なく行えましたが、やはり、FACEBOOK、TWITTER、UPLOADERがやはりだめでした。 同じように、レイアウトが崩れてしまい、アップローダーはエラーになってしまいます。 htaccessの記述や、サーバーのパーミッション、アップロード先ディレクトリーということになってきますと 難しくてわかりません。すいません。 |
| clothoweb > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/17 15:51 |
|---|
|
keijiさん、こんにちは。
利用してみていただいたパッケージは本体とテーマとプラグインの 構造をそのまま維持した形でコンポーネントしただけでしたので、 ディレクトリ関係は大丈夫なようにしているファイルでした。 一応、デバッグモードのいずれかを設定してみた上で エラー表示の内容だけでもこちらに貼り付けていただけたり、 またはスクリーンキャプチャなどがあると原因調査がしやすいです。 また、phpinfoなどの情報が分かると設定内容から 解決に繋がる要素などが見つかる場合もあります。 この一行だけでテキストファイルを作成し、ファイル名を変更して サーバーにアップロードしてアクセスすると確認できます。(例:info.phpなど) もう少し色々と調べてみますね。中々解決出来なくてすいません。 |
| keiji > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/18 3:51 |
|---|
|
本当にありがとうございます。
いろいろお手数をおかけいたします。 clothowebさんあてに情報を送らせていただきました。 宜しくお願いします。 |
| clothoweb > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/18 14:03 |
|---|
|
keijiさん、こんにちは。
プライベートメッセージありがとうございました。 色々確認してみましたが、ファイル構成やその他 問題点になりそうなところは見当たりませんでした。 そういえば、管理画面のエラーはどんな風に表示されますか? それと、これから以下の環境にしてインストールしてみます。 [php -v] 5.1.6 [php_flag] allow_url_fopen off allow_url_include off safe_mode on この状態でインストールを継続使用とすると、以下のような表示です。 引用: PHPセーフモード これでインストールしてみてどうなるか試してきますね。 |
| clothoweb > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/18 14:16 |
|---|
|
keijiさん、こんにちは。
エックスサーバーの上記環境で問題なく行けました・・・。 気がつくとMySQLのバージョンはエックスの方が古かったりもします。笑 あと思いつくのはPEARがサーバーにデフォルトで入っていないとダメとか? 一応、「baserCMSではPEARが必要」であった場合には、 以下の手順で申請すれば設定していただけるみたいですね。 http://www.wappy.ne.jp/support/faq/cgiphp.html#q5 長くなってしまって本当にすいません。けどもう少しのような気がします。 無理なく、確実に頑張って調べてみることにしますね。 |
| keiji > Re: Ecologyテーマを利用させていただいております。 @ 2012/7/18 18:55 |
|---|
|
clothowebさん、ほんとにありがとうございます。
ろくすぽ知識がないのに手がけようというのが悪いのでしょうか?ご迷惑をおかけいたします。 PEARが入っていないと駄目とか・・・。すいません、許容範囲超えてます(涙) サーバーに入れてくれといっちゃえば知らなくても大丈夫でしょうか? あと、safe modeですが、サーバー側ではoff、なのですが、インストール時onになっていました。 こちら側をoffにしなくてはいけないのでしょうか?cgiモードにしなきゃいけないのでしょうか? 今、とりあえず1系で、clothowebさんのスライダーにて予備のサイトを作ってます。 |

ユーザメニュー
