■ユーザーズフォーラム リニューアルのお知らせ
新規投稿は新ユーザーズフォーラムにお願いします。
このフォーラムは閲覧専用のアーカイブです。

80code.comでの設置

yuuki > 80code.comでの設置 @ 2010/6/13 23:57
■ BaserCMSのバージョン:1.5.7
■ レンタルサーバー名:80code.com
■ スマートURLの利用:ON
■ 設置フォルダ:ドキュメントルート
■ 利用しているデータベース:MySQL

上記環境でインストールを試みております。
Apacheモジュールの確認ができなかったため、.htaccessリネームを行ったところ
Internal Server Error 500 エラーがでてしまい、先に進めることができなくなりました。
(RewriteBase /を有効にしてもエラーが出たままです)

調べたところ、80code.comではmod_rewriteの使用はできるものの、その設定が独特であることがわかりました。
しかし、具体的な対処法などを見つけることができませんでした。
恐れ入りますが、どのように設定を行えばよいのか、ご教示いただければ幸いです。
non > Re: 80code.comでの設置 @ 2010/6/14 2:15
RewriteBaseを調整してもダメですか?

例えば、ドキュメントルートの.htaccessに

RewriteBase /


app/webroot/内の.htaccessに

RewriteBase /app/webroot


それでもダメな場合は、次のページを参考にしてみてください。

http://www.heartlogic.jp/archives/2007/07/80code.html
yuuki > Re: 80code.comでの設置 @ 2010/6/14 2:40
深夜にご回答ありがとうございます。
その後、ご呈示いただいたサイトを発見し、試してみたのですが相変わらず500エラーのままです。
RewriteRule なども変更してみましたが、変化ありませんでした。

できればBaserCMSを使いたいと思っております。
80code.comでの設置例がありましたら、引き続きご教示いただければ幸いです。
ryuring > Re: 80code.comでの設置 @ 2010/6/14 13:54
こんにちは。
残念ながら、80code.comでのBaserCMSの設置実績はありません。
BaserCMSは、CakePHPというフレームワーク上で動作しているのですが、80code.com で、CakePHPを動かすのは大変だという情報だけ見つけました。
http://www.heartlogic.jp/archives/2008/01/cakephp.html

「変化がない」だけではなくもう少し情報を頂けないと解決の糸口が見つけられません。
例えば、.htaccessを色々触ってみてこうやったら、うまく動作はしないが、エラー番号が変わった等。

.htaccessファイルは二つあるのですが、まずは一つずつ動作を試しましょう。

まずドキュメントルートの.htaccessだけリネームしてください。
そして、app/webroot/ 内に、例えば、test.html というファイルを作ります。
ドキュメントルートの.htaccessが正常に動作していれば、

http://xxx.xx/test.html でそのファイルが参照できるはずです。

もしできない場合、そのファイルがまず正常に動作していないので、編集を試みます。

まずは、
RewriteBase / 

がある場合とない場合の挙動を教えてください。

また、サーバーによっては、IfModule文があるとエラーになるところもあるようです。
<IfModule mod_rewrite.c>

と
</IfModule>

をコメントアウトした場合の挙動もおしえてください。

まずはここまでお願いします。

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

yuuki > Re: 80code.comでの設置 @ 2010/6/15 3:06
早急なご回答、ありがとうございます。不適切な質問をしてしまい、大変申し訳ございませんでした。
いろいろいじりすぎたので一度フォルダ内を削除し、再度アップしなおしてから検証いたしました。
検証ごとに「app/tmp/cache/persistent」をクリアにしています。

●.htaccess 使用前⇒step2まで無事に開ける。
 ・Apache Rewriteモジュール インストール状態→確認不能
 ・.htaccess ファイル書き込み権限→書き込み可
 ・.htaccess アップロード確認→アップロード未確認→[ステップ2]のCheckは完了、[ステップ3]へ。
 ・接続テストを行うと「データベースへの接続に成功しました。」のメッセージ→「次のステップへ」のクリックで下記エラー。step4が表示されない。
 Fatal error: Call to undefined method DboSource::connect() in /var/www/home/hogehoge/public_html/hogehoge/cake/libs/model/datasources/dbo_source.php on line 98
 
<Not Foundが出た書き換え>
●2箇所の.htaccess内「RewriteBase /」使用(The requested URL /app/webroot/ was not found on this server.)
●RewriteBase使用、rootはそのまま、/app/webroot/のみ「RewriteBase /app/webroot/」に書き換えた場合(The requested URL /app/webroot/ was not found on this server.)
●root内を下記に書き換え、
RewriteBase /
RewriteRule ^$ /app/webroot/ [L]
RewriteRule (.*) /app/webroot/$1 [L]
/app/webroot/内をに書き換えたとき(The requested URL /app/webroot/ was not found on this server.)
RewriteBase /
RewriteRule ^(.*)$ /index.php?url=$1 [QSA,L]
●root内を下記に書き換え、
RewriteBase /
RewriteRule ^$ /app/webroot/ [L]
RewriteRule (.*) /app/webroot/$1 [L]
/app/webroot/内を下記にに書き換えた場合(The requested URL /app/webroot/ was not found on this server.)
RewriteBase /
RewriteRule ^(.*)$ /index.php?url=$1 [QSA,L]
●root内を下記に書き換え、
RewriteBase /
RewriteRule ^$ /app/webroot/ [L]
RewriteRule (.*) /app/webroot/$1 [L]
/app/webroot/内を下記に書き換えた場合(The requested URL /app/webroot/ was not found on this server.)
RewriteBase /
RewriteRule ^(.*)$ /index.php?url=$1 [QSA,L]
●root内を下記に書き換え、
RewriteBase /app/webroot/
RewriteRule ^$ /app/webroot/ [L]
RewriteRule (.*) /app/webroot/$1 [L]
/app/webroot/内を下記にに書き換えた場合(The requested URL /app/webroot/ was not found on this server.)
RewriteBase /
RewriteRule ^(.*)$ /index.php?url=$1 [QSA,L]


★/app/webroot/内にtest.htmlを設置し、rootのみ.htaccessを設置したときは、それぞれ下記のエラーが出ます。

<Not Foundとなる書き換え>
●root内書き換え(The requested URL /app/webroot/ was not found on this server.)
RewriteBase /
RewriteRule ^$ app/webroot/ [L]
RewriteRule (.*) app/webroot/$1 [L]
●root内書き換え1(The requested URL /app/webroot/app/webroot/ was not found on this server.)
RewriteBase /
RewriteRule ^$ /app/webroot/ [L]
RewriteRule (.*) /app/webroot/$1 [L]
●root内書き換え2(The requested URL /app/webroot/app/webroot/ was not found on this server.)
RewriteBase /app/webroot/
RewriteRule ^$ app/webroot/ [L]
RewriteRule (.*) app/webroot/$1 [L]
●root内書き換え3(The requested URL /app/webroot/ was not found on this server.)
RewriteBase /app/webroot/
RewriteRule ^$ /app/webroot/ [L]
RewriteRule (.*) /app/webroot/$1 [L]
●root内書き換え4(The requested URL /app/webroot/ was not found on this server.)
# RewriteBase /
RewriteRule ^$ /app/webroot/ [L]
RewriteRule (.*) /app/webroot/$1 [L]
●root内書き換え5 およびを削除(The requested URL /app/webroot/ was not found on this server)
RewriteEngine on
RewriteBase /
RewriteRule ^$ app/webroot/ [L]
RewriteRule (.*) app/webroot/$1 [L]

<500Internal Server Errorが出た書き換え>
●rootのみデフォルトのままリネームしたとき
サーバーのエラーログ
mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use 'RewriteOptions MaxRedirects' to increase the limit if neccessary.
●デフォルトの記載のままおよびを削除したとき
サーバーのエラーログ
mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use 'RewriteOptions MaxRedirects' to increase the limit if neccessary.

<そのほかのエラー>
●rootはデフォルト記載のまま、/app/webroot/ におよびを削除したものをアップ
Fatal error: Call to a member function trigger() on a non-object in /var/www/home/hogehoge/public_html/basercms/cake/libs/model/model.php on line 2011
(このエラーは、下記記載の2パターン、および「RewriteBase /」を使用したときも同じものでした)
RewriteRule ^(.*)$ index.php?url=$1 [QSA,L])
RewriteRule ^(.*)$ /index.php?url=$1 [QSA,L]

長々と申し訳ございません。まずはここまで検証いたしました。
どうぞよろしくお願いいたします。
yuuki > Re: 80code.comでの設置 @ 2010/10/19 2:38
過日は大変お世話になりました。
あれからしばらく検証できず、放っておいたのですが、昨日再び取りかかることがで来ました。
結論から申し上げますと、最新バージョンでのインストールに成功いたしました。

実は、6月にいじっていた1.5.9の時点では、80code.comで提供されるドメインのままであれば、スマートURLを利用した設置は可能でしたが、独自ドメイン上ではスマートURLを利用することがで来ませんでした。
そこで昨日、一度全てをアンインストールし、1.6.6の最新バージョンで再度インストールを試みました。
すると.htaccessをマニュアル通りに書き換えるだけで、独自ドメイン上でもスマートURLを利用できるように設定した上で、インストールを完了させることができました。

結局どういう理由で認識されなかったのかさっぱりわかりませんが……。
その後、自身が忙しくなり、いじる時間がとれなくなってしまったこと、そしてサポートからの返事もなくなってしまったため、ご連絡差し上げることができませんでした。
大変申し訳ございませんでした。

ただし、別の問題があるようです。
インストール後、表示・登録・新規ページ作成などは正常に行えるのですが、デバックモードにするとHOMEのみ下記のエラーが出ています。
Notice (8): Undefined index:  QUERY_STRING [CORE/baser/basics.php, line 155]


上記のエラーのせいか、新たなプラグインの登録も出来ないようです。
どのプラグインも画面上では通常に登録できたように表示されるのですが、「管理」をクリックすると下記のメッセージが出ます。
エラー:  TwitterController が見つかりません。
エラー: クラス TwitterController を app/controllers/twitter_controller.php ファイル内に作成してください。


上記指示に従い、プラグイン内のtwitter_controller.phpをapp/controllers/内に設置すると、今度は下記のエラーが出ます。
エラー:  モデル Twitter のデータベーステーブル bc_twitters が見つかりません。


……実はこれが仕様で、全て手動で設定すべき事項でしたら大変申し訳ございません。
念のためご報告の上、ご教示いただければ幸いです。
ryuring > Re: 80code.comでの設置 @ 2010/10/19 8:35
おはようございます。

yuukiさんご報告ありがとうございます!

引用:
.htaccessをマニュアル通りに書き換えるだけで、独自ドメイン上でもスマートURLを利用できるように設定した上で、インストールを完了させることができました。
結局どういう理由で認識されなかったのかさっぱりわかりませんが……。


インストールまわりは随時改善しているのでそれでよくなったのかもしれません。
どれが原因というのは僕も特定できませんが。。


引用:
インストール後、表示・登録・新規ページ作成などは正常に行えるのですが、デバックモードにするとHOMEのみ下記のエラーが出ています。
Notice (8): Undefined index:  QUERY_STRING [CORE/baser/basics.php, line 155]



ちょっと basics.php を調整してみました。
次のURLからダウンロードして上書きしてみてください。
http://project.e-catchup.jp/projects/basercms/repository/revisions/680/entry/trunk/baser/basics.php

引用:
上記のエラーのせいか、新たなプラグインの登録も出来ないようです。


上記のエラーが問題となっているかは特定できませんが、basics.php を上書きした後で、一旦削除した上で再登録してみてください。



Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

yuuki > Re: 80code.comでの設置 @ 2010/10/19 10:38
お世話になっております。
早速のご対応ありがとうございました。
引用:

ちょっと basics.php を調整してみました。
次のURLからダウンロードして上書きしてみてください。
http://project.e-catchup.jp/projects/basercms/repository/revisions/680/entry/trunk/baser/basics.php


上書き後、確認してみたところ、HOMEのみ表示されていたエラーは表示されなくなりました。ありがとうございました!
ただし、新たなプラグインの登録については現在も上記の状態のまま変化ありませんでした。
これから別のアカウントで再度インストール&テストしてみようと思いますが、なにか解決の道筋があるようでしたらご教示いただければ幸いです。

取り急ぎご報告申し上げます。
ryuring > Re: 80code.comでの設置 @ 2010/10/19 11:06
こんにちは。ご報告ありがとうございます。

ちなみに、アップローダープラグインをインストールした場合も同じ症状になるか確認して頂けますか?

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

yuuki > Re: 80code.comでの設置 @ 2010/10/19 12:24
お世話になっております。
この度はいろいろとありがとうございました。

プラグインの件ですが、どうやらインストール時に「プラグインのフォルダ名を「baser」しか除かず、バージョンナンバーを残したままアップ」してしまったために、いろいろ認識できなかったようです。
いずれのプラグインも、プラグイン名のみとなるよう修正したところ、正常に認識し、稼働するようになりました。
当方のうっかりミスでした。お手を煩わせてしまい、大変申し訳ございませんでした。

これで、あとはデザインを作成すれば公開できそうです。本当に使いやすくて、ありがたく思います。
公開した際にはご報告をさせていただきます。
取り急ぎお礼申し上げます。ほんとうにありがとうございました。