■ユーザーズフォーラム リニューアルのお知らせ
新規投稿は新ユーザーズフォーラムにお願いします。
このフォーラムは閲覧専用のアーカイブです。

ビューがありません とは?

Becky > ビューがありません とは? @ 2010/6/20 13:38
初めまして。本日初めてこのCMSを使わせて頂きます。
インストールについての質問をお願いします。
ファイルをFTPでアップロード後、.htaccessをリネームしました。
その後、cms_controller.phpを作りなさいとのエラーがありましたので
/app/controllers/以下に記述
----------
class CmsController extends AppController {
var $name = 'Cms';
function index() {
}
}
?>
--------
その後、下記エラーが表示されてしまいます。
/app/views/以下にはcmsフォルダはありません。
--------
ビューがありません
エラー: ビュー CmsController::index() が見つかりません。
エラー: ファイル /var/www/vhosts/****.jp/httpdocs/cms/app/views/cms/index.ctp を作成したことを確認してください
注意: このエラーメッセージをカスタマイズしたい場合は、 app/views/errors/missing_view.ctp を作成してください
--------

何か.htaccessの記述でも間違ってしまってるのでしょうか?
お力を貸してください。


BaserCMS1.5.9:
お名前 VPS Apache2 CentOS5.5
MySQL4 の予定ですがまだインストールまでいけてません
non > Re: ビューがありません とは? @ 2010/6/20 22:53
おそらくcmsというサブフォルダに設置していて、.htaccessの設定がちゃんと行えていないのが問題じゃないでしょうか?

cms 直下の.htaccessに

RewriteBase /cms/


cms/app/webroot 直下の.htaccessに

RewriteBase /cms/


もしくは、

RewriteBase /cms/app/webroot/


と書いてみてはどうでしょう?
Becky > Re: ビューがありません とは? @ 2010/6/20 23:46
nonさん ありがとうです。
おっしゃるように記入しておりました。
webroot の.htaccess には 下記を記入してました。
--
RewriteBase /cms/app/webroot/
--
/app/以下にもhtaccess.txtがありましたが、これは削除しました。

エラー: ビュー CmsController::index() が見つかりません。
これはどういう意味なんでしょうね。

また、coreserver.jpにもインストールを試みてみましたが、403エラーになってしまっていて。
自分のPC(Mac)にもいま、xamppで入れてる最中なんです。
他の皆さんはエラーないのですよね?
様々なCMSをテストでランニングさせてますが、今までこのようなエラーは出てきたことがないので不思議です。
non > Re: ビューがありません とは? @ 2010/6/21 0:13
エラー: ビュー CmsController::index() が見つかりません。


これは、オープンソースフレームワークであるCakePHPが出力するエラーメッセージなのですが、.htaccess の設定がおかしいので、
BaserCMSの設置ディレクトリが判断できない為に出力されています。

おそらく、

http://xxx.xx/cms/ という場所に設置しているんだと思うのですが、

http://xxx.xx/ という場所に設置していると認識されています。(これはRewriteBaseの設定の問題)

通常、CakePHPは、設置場所のスラッシュから次のスラッシュまで(要するに今回の場合cms)の文字列をコントローラープログラムの情報として認識します。
※ コントローラーについてはMVCでぐぐってください。

今回の場合、cmsというURL上の文字列をプログラムファイルの情報と誤認識しているだけなので、もちろん、BaserCMSには、cmsという文字列に関連するプログラムがなくエラーとなります。

例えばhogeというフォルダにBaserCMSを設置しているならば、
エラー: ビュー HegeController::index() が見つかりません。

と出力された事でしょう。

RewriteBaseの設定は環境によってシビアです。

設置したいサーバー名とCakePHPというキーワードで検索するとRewrite関連の情報を何か情報が得られるかもしれません。


---
CPIは知りませんが、CORESERVERは動作確認済だったはず。(特殊な設定が必要だったような)
http://basercms.net/manuals/introductions/2.html
Becky > Re: ビューがありません とは? @ 2010/6/21 1:44
nonさん いろいろありがとうございます。
原因がわかりました。
ディスクトップに解凍したときにファイルが壊れていたと思われます。

onamae VPS上でsshでwgetして解凍し、パーミッションを変更したら、エラーも全く出ず。
DBのアクセスまですんなりいってしまいました。

Coresereverでも壊れたファイルでFTPアップしたために403errerが出ていたと思われます。
なんて、くだらないミスをしてしまったのでしょう。
いろいろお教え頂けたことありがとうございます。
CakePHPも少しづつ、マスターしていきます。
感謝です。