エックスドメインでインストール
| n1215 > Re: エックスドメインでインストール @ 2014/2/14 22:24 |
|---|
|
haluna 様
恐らく回答が手遅れだとは思いますが、個人的に無料サーバへのインストールは気になったので先ほど試してみました。 ●原因 エックスドメインの無料サーバの広告挿入が原因ですね。 ファイルの中の<body [属性]>という文字を検出して、その後ろに<script>タグを埋め込むという少し配慮が足りない仕様のようです。 htmlファイルの場合は問題ないのですが、例えばjsファイルに挿入されると今回のように不幸なことになります。 今回はjqueryのファイルがひっかかっています。 ●対策:jqueryのファイルを一部書き換える lib/Baser/View/webroot/js/admin/jquery-1.7.2.min.js minfyされているので何行目などとは指しづらいですが最初のほうの下記部分にある<body>という文字を ------------------------------------- "<!doctype html>":"")+"<html><body>") ------------------------------------- スクリプトの処理を変えないよう変更して ------------------------------------- "<!doctype html>":"")+"<html><bod" + "y>") ------------------------------------- とでもしてやればこの杜撰なチェックからは逃れられます。 (jquery本体に手を入れるというのは褒められたものじゃないですね。 baserCMSに利用されているjqueryのバージョンアップにより<body>の記述がなくなることを期待) ※nada-iconsをインストールした場合は下記も変える必要があると思います。多分。 app/webroot/theme/nada-icons/js/jquery-1.7.2.min.js app/webroot/theme/nada-icons/js/admin/jquery-1.7.2.min.js ●インストールその後 step5でエラーが出ますが、インストール自体は完了しました。 管理画面より固定ページの書き出しを実行すると(step5のエラーのせいか?)出力されていないページも表示できます。 しかしながら、会社案内のページは完全に崩れます。 An Internal Error Has Occurred.と表示されコンテンツ部分がdoctype宣言より前に挿入されていました。 デバッグモードで確認した所Google Mapの出力の際にxml周りでひっかかっているみたいですね。 phpinfo()が使えないサーバのようなのでこれ以上の分析と対策は少し面倒くさいです。 ●まとめ 他にもエラーが出そうではありますが頑張れば運用できなくもなさそうです。 (試してないですがお問い合わせフォームはあやしい気がしますね) Twitter: @n_1215 |
| haluna > Re: エックスドメインでインストール @ 2014/2/14 23:56 |
|---|
|
n1215様
お返事ありがとうございます。 まさか検証していただけるとは!!<(_ _*)> やはり広告挿入JSが原因でしたか・・・ 無料サーバーは魅力的ですが、スキルの低い私には壁が高いです・・・ 検証ありがとうございました。 |


