coreserverでインストール時にエラーでstep2から進めません
| cocoa > coreserverでインストール時にエラーでstep2から進めません @ 2014/2/9 1:08 |
|---|
|
お世話になっております。
約1年前と、昨年夏頃に、2つのサイトにbaserCMS2.0.5.1をインストールして利用しています。 今回、3.0.1が出たということで、 新規にインストールして、これまでのデータを移そうかと考えています。 早速ですが、 3.0.1をインストールしようとしているのですが、 ステップ2から、全く進めなくなってしまいました。 環境は coreserver(core miniです。) baserCMS3.0.1 PHP 5.2.5 MySQL 5.1.22-rc PHPセーフモードはoff 2系の時の、インストール覚え書きをたよりに、色々と試してみましたが、 エラーが出てしまって進めません。 どのように対処すれば良いのか、教えて頂けると大変ありがたいです。 どうぞよろしくお願い致します。 |
| cocoa > Re: coreserverでインストール時にエラーでstep2から進めません @ 2014/2/9 10:03 |
|---|
|
お世話になっております。
昨夜、上記のエラーで進めなかったのですが、 今朝、再度、http://mywebsiteにアクセスすると、 step2で出ていたエラーが消えて、その後へ進みました。 データベース接続設定までスムーズに行きました。 (この時点では。。。) ところが、その後、今度は、color=EF2929]『(step4が?)見つかりませんでした。』[[/color]というエラーが出ました。 app/config/install.php ファイルを、 削除したり、また前の状態に書き替えて置いてみたり、 他のファイルのパーミッション設定だとか、 色々試しているのですが、install.phpファイルを削除すると、次のエラーが出ますし、 install.phpファイルを戻すと、 このようにエラーだらけになってしまいます。 どうすれば良いでしょうか?(泣) 教えていただけると、大変ありがたいです。 どうぞよろしくお願い致します。 |
| goichi > Re: coreserverでインストール時にエラーでstep2から進めません @ 2014/2/9 22:19 |
|---|
|
coreserverは使ったこと無いのですが、エラーメッセージをみる限り、キャッシュファイルを生成する時に、うまく行っていないような感じではないでしょうか?表示されている
で検索してみると、色々と出てきました(パーミッション絡みっぽいです)。たしか、coreserverは2系統をインストールするにも、色々と設定しないといけなかったと思います。ちょっと今の段階では情報が出てませんが、ver3でも何かそういう工夫が必要なのかも知れません。 直接の回答でなくて申し訳ないのですが、とりあえず怪しいのは/app/tmp/というキャシュフォルダ(とその中身)ではないかと思います。参考までに投稿しておきます。m(__)m |
| cocoa > Re: coreserverでインストール時にエラーでstep2から進めません @ 2014/2/10 1:35 |
|---|
|
goichiさん
ご回答、誠にありがとうございます。 自分でも色々試していました。 そして、 もう一度、ファイルをFTPするところからやり直し、 やはり、以前の2系の時の覚え書き通りに、やってみました。 ◆baserCMSインストール覚え書き(1年ほどまえの、BaserCMS2.0.5.1の時のものです。) 以下、coreserver(core-miniプラン)用設定。 http://Myドメイン/ で利用。 baserCMS 2.0.5.1 PHP 5.2.5 MySQL 5.1.22-rc PHPセーフモードはoff 1) インストール時 /.htaccess に、 AddHandler application/x-httpd-phpcgi .php mod_gzip_on Off を記述。 2) app/tmp/ 以下に次のフォルダをあらかじめ作り、パーミッションを707(または777)にする。 cache/datas/ /environment/ /models/ /persistent/ /views/ csv/ logs/ schemas/baser/ /plugin/ sessions/ 3) ■ ファイルは全て確実に上がってるかどうか? ■ /app/tmp 以下に全て書込権限が与えられているか? ■ トップの .htaccess ファイルに書込権限が与えられているか? ■install.php に書込権限が与えられているか? ■ /app/webroot/themed/YOUR_THEME/pages 配下のフォルダ・ファイルに書込権限が与えられているか? ■ /app/config/install.php の以下の箇所を書換え Configure::write('App.baseUrl', $_SERVER['SCRIPT_NAME']); ■ 以下のURLにアクセス http://Myドメイン/index.php/admin 4) 固定ページの新規登録に、 > 日本語の入力が可能です。 となっているが、フォルダ、ファイルにアクセスできないエラーを起こすので、 (固定ページのページ名に)日本語は使わない。 だいたい以上のようなことでした。 作業を行っているのは、MacBookで、sarariをメインに使っています。 step2、他でエラーが出たのは、safariでした。 念のため、Firefoxでもやってみました。 すると、インストールはできてしまいました。 最後に、このイメージのようなエラー出てしまいます。 とりあえず、 safariでも、webサイトのトップ画面、管理画面にも入れて、大丈夫みたいです。 リンク先のページが無いことで(今度は・・・)エラーが起こっているみたいです。 2系の、覚え書きを、引っ張りだしてきて、再度、良く確かめてみたいと思います。 また、何か、ありましたら、ご報告させて頂きます。 インストール自体はできたので、とりあえず、『解決済』とさせていただきました。 |
| cocoa > Re: coreserverでインストール時にエラーでstep2から進めません @ 2014/2/10 18:55 |
|---|
|
お世話になります。
一端、とりあえずはインストールできたはずなのですが、 やはり、エラーが出るので、 何度か、ソースをアップロードするところからやり直しています。 ブラウザは(Mac版)Safariと、Firefoxで確認するようにしています。 前回、記したように、 全部のソースをUPし、 パーミッション設定をフォルダは777、書き込みしないといけないファイルは666に設定。 必要なファイルも追加でUPして、インストール開始ボタンをクリックし、 最初は、セーフモードがONになっているとでてくるので、 ここで、.htaccessに、 AddHandler application/x-httpd-phpcgi .php mod_gzip_on Off を記述し、ドメイントップに置き、パーミッションを666に設定。 『再チェック』をクリックすると、 どうしても、次のようなエラーが出て、回避されません。 Warning (2): session_start() [function.session-start]: open(/tmp/sess_a09p0vjdqsn6scpse341f5mhj2, O_RDWR) failed: Permission denied (13) [CORE/Cake/Model/Datasource/CakeSession.php, line 610] Warning (2): session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /virtual/myweb/public_html/mybaserSite/lib/Cake/Utility/Debugger.php:802) [CORE/Cake/Model/Datasource/CakeSession.php, line 610] 思い当たるところは全部チェックしたつもりなのですが、 何度アップロードからやり直しても、どうしても、ここから進めません。 当方のサーバーは、 core-miniサーバーです。 PHP 5.2.5 MySQL 5.1.22-rc PHPセーフモードはoff 再度、申し訳ありませんが、どこに問題があるのか、教えていただけると大変ありがたいです。 どうぞよろしくお願い致します。 |
| cocoa > Not Found エラーがでたり、真っ白い画面になります。 @ 2014/2/10 22:44 |
|---|
|
こんばんは。
お世話になります。 前回と同じパターンですが、 一応、インストールは出来ましたが、やはり、パスが違っているらしく、 Not Foundエラーがでます。 以下、最後に、もう一度、最初からインストールした際の状況も含めて書きます。 basercms 3.0.1 PHP 5.2.5 MySQL 5.1.22-rc PHPセーフモードはoff 1)SQLデータベースを準備。 2)http://mysite.net/ にbaserCMSソースを全部アップロード 3)http://mysite.net/ へアクセス 4)『インストールを開始』ボタンをクリック ★インストール前に、(4)の『.htaccess』を先に置くとエラーを起こす。 5)PHPセーフモードがONのままなので、次の2行のみを、.htaccessに記述して、 ドメイントップへ置き、パーミッションを666にする。 AddHandler application/x-httpd-phpcgi .php mod_gzip_on Off # 以下は、core-miniではNGだった。(分かりませんが。。多分。) # AddHandler application/x-httpd-php54cgi .php # mod_gzip_on Off app/tmp/ 以下に次のフォルダを(『.htaccess』書き換えと一緒に)作り、パーミッションを707(または777)にする。 cache/datas/ /environment/ /models/ /persistent/ /views/ csv/ logs/ schemas/baser/ /plugin/ sessions/ 最初は、step2あたりで、再チェックすると、中身的にはエラーではなさそうですが、文字化けしてしまいます。 ブラウザを終了してから、再度、最初からやってみたり。。。でも、同じパターンでした。 (勿論、その都度、キャッシュをクリアしました。) (しばらく、このままの状態で席を外していて(気分転換に、夕食?(^_^;))、 戻ってから、最初からやってみると、エラー表示が出なくなり、次の処理も行った後、インストール完了メールが届きます。) step5でエラーがでたので、 既成されているinstall.phpに、 Configure::write('App.baseUrl', $_SERVER['SCRIPT_NAME']); を追加。 Configure::write( で記述されている最後に追加したので、最後からは3行目。 これで、インストール完了ページまでたどり着きました。 この後、 トップページを確認。 http://mysite.net/ へアクセスすると、トップページはキレイに見られました。 その後、ホームをクリックすると、 Not Found エラー: The requested address '/index.php/index.php/' was not found on this server. と表示されます。 他のページも、Not Foundが表示されるか、真っ白い画面になっています。 エラーに表示されているように、index.php/index.php/がダブっているので、 パスが違うのだろうということは分かりますが、 どこを修正すれば良いでしょうか? それから、 前回、エラーが表示されてしまったのは。。。 『サイト基本設定』ページで、 公開状態 公開中 制作・開発モード ノーマルモード になっていますが、 これを、 公開状態 メンテナンス中 に切り換えた後、 どのページも表示されなくなり、 管理画面に入ろうとURLを入れ直しても、 http://mysite.net/maintenance (だったと思いますが。。。) このページで真っ白な画面しか出なくなってしまっていました。 今回は、(まだパスがおかしい状態なので・・) 公開中のままにしています。 長くなりましたが、現状、このような感じなのですが、 パスが違っているために、Not Foundと表示されるのだと思いますが、 どこを変えれば良いのか、アドヴァイス頂けるとありがたいです。 どうぞよろしくお願い致します。 P.S. その後の状態を、詳細に投稿しようとしましたが、折角書いたのに、はねのけられてしまいました(涙) また後ほど、仕事が終わってから投稿します。 とりあえず、現状、Not Foundが消えず、テストで上書き投稿すると、最初は見えるけれど、後から、 Not Foundになります。。。。 3.0.1を使うのは無理でしょうか。。。 |
| cocoa > 今度は、更に、一面エラー画面になります。 @ 2014/2/11 19:04 |
|---|
|
お世話になります。
更に、何とか自己解決しようと、色々と試していますが、 一度、デバッグモード1、デバッグモード2、デバッグモード3を順番に試して、 確認、今度は、元に戻そうとしても、一面、エラーだらけで、普通に見られなくなってしまいました。 文字化けしていましたが、文字コードを変更して見てみると、 図のようなエラーが出ています。 コントローラがありません エラー: Index.phpController が見つかりません。 エラー: クラス Index.phpController を app/Controller/Index.phpController.php ファイル内に作成してください。 class Index.phpController extends AppController { } 注意: このエラーメッセージをカスタマイズしたい場合は、 app/View/Errors/missing_controller.ctp を作成してください Stack Trace APP/webroot/index.php line 146 → Dispatcher->dispatch(CakeRequest, CakeResponse) ROOT/index.php line 53 → require(string) このエラーを回避するのには、どうすれば良いでしょうか? 何とか、BaserCMS3.0.1を使いたいと思って、自分でも色々と試しているのですが、core-miniサーバーでは無理でしょうか? よろしくおねがいします。 |
| tecking > Re: 今度は、更に、一面エラー画面になります。 @ 2014/2/11 19:40 |
|---|
|
cocoaさん
PHPのバージョンが 5.2.5 とのことですが、これだとそもそもbaserCMSのシステム要件(5.2.17以降)を満たさないですよね。 システム要件 http://basercms.net/about/system PHP: Releases http://www.php.net/releases/ |
| masa77 > Re: 今度は、更に、一面エラー画面になります。 @ 2014/2/11 21:33 |
|---|
|
cocoaさん
大変ですね、よくわかります。 coreserver core mini での私の経験を書きます。 basercms 2系は問題なくインストール出来ていました。 ***** 2系 では 下記 .htaccess で OKでした。 AddHandler application/x-httpd-phpcgi .php mod_gzip_on Off ところが、basercms 3系では cocoaさんと同じ症状でした。 入れたり出したり、、、泥沼状態でした。 現在は3つ入れ色々テストしております。 core miniではデーターベースが複数作成できるので データーベースを新規に作成し、念の為サブフォルダー(例:ba)に入れる。 basercms 3.0.1を解凍して出来た .htaccess の 最終行の次に 下記 54を 追加する。 (先頭に#つかない) # 【動作確認済レンタルサーバー】 # http://basercms.net/manuals/introductions/2.html # AddHandler application/x-httpd-php54cgi .php mod_gzip_on Off 残りと一緒にサーバーに転送し、インストールを始める。 無事インストールでき、更新時には、ブラウザーのキャッシュを削除、Baserのサーバーキャッシュ削除を行う。 無事完了され問題なければ、トップに入れられてはどうでしょうか。 |
| cocoa > Re: 今度は、更に、一面エラー画面になります。 @ 2014/2/12 0:35 |
|---|
|
teckingさん、
コメントありがとうございます。 > PHPのバージョンが 5.2.5 とのことですが、これだとそもそもbaserCMSのシステム要件(5.2.17以降)を満たさないですよね。 5.2.5って、5.2.17よりは上ではないのですか? 何故、満たさないのか、よく分かりません。。。 |
| cocoa > Re: 今度は、更に、一面エラー画面になります。 @ 2014/2/12 1:06 |
|---|
|
masa77さん、
ご丁寧に、ありがとうございます。 AddHandler application/x-httpd-php54cgi .php mod_gzip_on Off に#を付けていたのは、すでに、何度か試したので、コメントアウトしたまま転載したからです。 ご回答下さってから、 もう一度、全部、削除して、 新しくダウンロードし直しして、.htaccess を不可視のまま、他のファイルと一緒に、 アップロードせずに、 上記の2行を付け加えてアップロードし、該当サイトにアクセスし『インストール開始』しようとすると、次のようなエラーになり、進めません。 Script Error The script did not produce proper HTTP headers. Please see the error log to see the detail of the errors. Depending on the server configuration, you can also run thisscript under CGIWrap debugging. Usually, either rename or linkthe script temporarily to a file which ends with .phpdextension, or add a AddType application/x-httpd-phpcgi-debug .phpline to your .htaccess file. (.htaccess をリネームしておいて ) 『インストール開始』をクリックしたあと、step2で、 PHPセーフモード On となっているので、 ここで、上記の2行を入れた .htaccess のファイル名を元通りにし、パーミッションも確認して、 ブラウザのキャッシュをクリアし、『再チェック』をクリックすると、 やはり、次のエラーが出ます。 Script Error The script did not produce proper HTTP headers. Please see the error log to see the detail of the errors. Depending on the server configuration, you can also run thisscript under CGIWrap debugging. Usually, either rename or linkthe script temporarily to a file which ends with .phpdextension, or add a AddType application/x-httpd-phpcgi-debug .phpline to your .htaccess file. ブラウザのキャッシュをクリアして、.htaccessに次の2行を書いたものを使うと、 AddHandler application/x-httpd-phpcgi .php mod_gzip_on Off 文字化けし、次のスクリーンショットの通り、エラーが出ています。 Warning (2): session_start() [function.session-start]: open(/tmp/sess_39uvpojhf33o9pdpkrc44t7ub5, O_RDWR) failed: Permission denied (13) [CORE/Cake/Model/Datasource/CakeSession.php, line 610] Warning (2): session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /virtual/mywebID/public_html/mysite/lib/Cake/Utility/Debugger.php:802) [CORE/Cake/Model/Datasource/CakeSession.php, line 610] ブラウザのエンコーディングを手動で直せば見られるので、確認してみると、 ヘッダー部分には、上記のエラーが出たままですが、 『次のステップへ』は行けます。 でも、結局、ここのエラーをキチンと処理できていないからだと思うのですが、、。 勿論、各フォルダは(面倒ですけれど。。。(^_^;)) 全部、パーミッションを777にしています。 書き込む必要があるファイルは、666に設定。 何が、NGなのかが、さっぱりわかりません。 折角、教えて下さったのに、申し訳ありません。 同じ、core miniサーバーで、何が違うのでしょう。。。(泣) これを解決できないと、 複数行う予定だった、webサイトの更新は、BaserCMS3.0.1は断念せざるを得ません。 2系と3系では、やはり3系の方が良いのでしょうか? |
| tecking > Re: 今度は、更に、一面エラー画面になります。 @ 2014/2/12 10:03 |
|---|
|
cocoaさん
引用: teckingさん、 PHP: Releases http://www.php.net/releases/ にあるように、5.2.5が2007年11月8日、5.2.17が2011年1月6日のリリースとなっています。 CORE MINIで動作している方もいらっしゃるので PHPのマイナーバージョン違いが原因というわけでもなさそうですね。 決定打を示せず申し訳ないですが…… |
| goichi > Re: 今度は、更に、一面エラー画面になります。 @ 2014/2/12 11:00 |
|---|
|
横槍ですみません、ちょっと気になったのですが、セッションエラーがでている部分については、baserCMSに限らず他の方もこまっているようで、こんな記事もあるようです。
coreserverをよく知らないのですが、エラーメッセージの という部分に書いてある/tmp/〜というのは、共有サーバーで利用できない領域の場所ではないでしょうか? そうであるならば、上記の記事の示す通り、php.iniでセッションの一時ファイル場所を自分の好きな所に設定すれば、このエラー自体は消えると思います。 ちなにに、cakePHPのセッションの保存先を変更するというワザもあるようです。いまのバージョンと書き方が違うかもしれませんが、/app/Config/core.phpに似たような記述(220行目付近)がありますので、そこを書き換えれば良いのかも知れません。 baserCMS3が出たばかりで、情報が少ないので、一つ一つ確かめるしか無いのが現状だと思います・・・・。ちょっと大変ですが、参考までに投稿しておきます。 |
| masa77 > Re: coreserverでインストール時にエラーでstep2から進めません @ 2014/2/12 14:52 |
|---|
|
今調べてみましたら、
PHP 5.5.3 MySQL 5.1.22-rc でした。 私も、Script Error とか セーフモード、SQLite で作製出来るとか。。。 Warningが なんたらかんたらと・・・・cocoaさんと同じようなものが色々でました。 何度か再インストールも行いましたが、同じような症状でした。 パーミッションも色々変更しましたが、解決せず。 良いかどうかわかりませんが、自己責任として行いました。 最後の手段として、サーバーのBaser関連および他のデーターベース関連もすべて削除 データーベースも最初のデーターベース以外をすべて削除した。 最初のデーターベースの PhpMyAdmin に入り関連項目をすべて削除。 再度、baserCMS3.0.1 ダウンロードし 解凍して .htaccess に下記を追記 サーバーに転送 AddHandler application/x-httpd-php54cgi .php mod_gzip_on Off これでやっと、無事運用出来るようになりました。結果オーライーかな。 |
| cocoa > Re: 今度は、更に、一面エラー画面になります。 @ 2014/2/13 3:21 |
|---|
|
teckingさん
ご説明頂き、PHPのバージョンの件、少しわかりました(^_^;) ありがとうございます! |
| cocoa > Re: coreserverでインストール時にエラーでstep2から進めません @ 2014/2/13 3:38 |
|---|
|
masa77さん
ご丁寧に、コメントを頂き、ありがとうございます。 私も、 再インストールする際には、データベースを、一端削除し、再度、新たにデータベースを作って、 それから、インストールするようにしています。 PHP 5.5.3 ですか。。。 今、coreserverのコントロールパネルから確認したところ、 PHP 5.5.3 になっていました。 だけれど、 インストール作業のステップ2で確認できるのは、 5.2.5 なんですよね。。。 何故なんでしょうね。。。 とりあえず、 このまま、色々と検証してみたいのですが、 明日も、本業で時間が取れませんし、14日から16日までは、留守します。 (MacBookを持っていきたいところですが。。。(^_^;) 多分、 もう一度、作業できるのは、来週、18日以降になってしまう見込みです。 色々と、ヒントを頂いたことを元に、また試してみたいと思います。 以上の理由で、スグに、ご返信できないことがありますが、 解決したいと思っていますので、 どうぞよろしくお願い致します |
| オージェバング > Re: coreserverでインストール時にエラーでstep2から進めません @ 2014/2/16 17:46 |
|---|
|
はじめましてオージェバングと申します。
coreserverへのインストールですが私は2系3系と問題なく可能でサイトも稼動させおり プランはCORE-MINIとCORE-Aを両方使っています。 < coreserverのPHPの仕様 2014/2/16情報> PHP5.2(モジュール版) PHP5.3(CGI版) PHP5.4(CGI版) PHP4/5/6(CGI版) となっています。 ・モジュール版はパーミッションの設定が必要。 ・CGI版はパーミッションの設定は必要無い。 参考URL http://www.coreserver.jp/help/index.php/phpcgi/ < coreserverのDBの仕様 2014/2/16情報> SQLiteおよびMySQL使用可能。 < サーバー仕様でインストール時問題となる点 2014/2/16情報> セーフモードがonになっているのでoffにする。 これらを踏まえてPHP5 CGIモードで稼動させるとして .htaccessに以下を書き加えます。 これで稼動させているサイトは未完ですが http://www.wwz.jp/ です。 coreserverでインストールの際に注意している点は 「インストールする前(インストールページを開く前)に.htaccessをcoreserver仕様に変更しアップロードする。」 で、以前何度かインストールセットアップをはじめてエラーが表示されると修正しても以後エラーが表示されて後に進めず、 ファイルアップロードから始めなければなりませんでした。 ブラウザのキャッシュを削除すれば成功する事もあるのですが 「 baserCMSダウンロード → 解凍後.htaccessを修正(追記)→アップロード→ブラウザを開いてインストール 」 の流れでインストールする様になってからはエラー表示で先に進めない事はありませんでした。 理由が説明できないのでオカルト的ですがcoreserverにインストールする時は 「サーバーの仕様を確認して.htaccessを修正(追記)してアップロードするまでインストール画面を開かない」 が私の鉄則です。 ********************************************** |
| cocoa > Re: coreserverでインストール時にエラーでstep2から進めません @ 2014/2/17 20:04 |
|---|
|
オージェバングさん
色々と経験された情報を、ありがとうございます。 今日は、もうこれから、試す元気が無いので(^_^; 明日以降、教えていただいたことも含めて、 試してみたいと思います。 経過報告になるか、結果報告になるかは、まだわかりませんが、 勿論、また、こちらへご報告させて頂きます。 |
| cocoa > Re: coreserverでインストール時にエラーでstep2から進めません @ 2014/2/18 1:02 |
|---|
|
オージェバングさん
再度、 BaserCMS3.0.1をアップロード MySQLデータベースも、新しく作り直し、 app/tmp/ 以下に次のフォルダを(『.htaccess』書き換えと一緒に)作り、パーミッションを707(または777)にする。 cache/datas/ /environment/ /models/ /persistent/ /views/ csv/ logs/ schemas/baser/ /plugin/ sessions/ そして、 .htaccessファイルに、 を入れて、 Mywebサイトにアクセス。 すると、これまでと違って、 エラーを起こさず、スムーズにインストールが完了しました♪ (ちなみに、x-httpd-php53cgi部分を、 x-httpd-php54cgiにすると、やはり、 これまでと同様、エラーを起こしてインストールできませんでした。) インストール自体は、スムーズに完了できたと思います。 ありがとうございました! しかしながら、 やはり、トップページ(index.phpが付いた場合。)のみ、エラーを起こしてしまいます。 (Not foundと出ます。。。) 別立てで質問したいと思います ひとまず、 コメント下さったみなさま、ありがとうございました♪ |


