■ユーザーズフォーラム リニューアルのお知らせ
新規投稿は新ユーザーズフォーラムにお願いします。
このフォーラムは閲覧専用のアーカイブです。

さくらのレンタルサーバ プレミアムでページを更新すると500エラーになる

kouki > さくらのレンタルサーバ プレミアムでページを更新すると500エラーになる @ 2011/12/26 13:32
さくらのレンタルサーバ プレミアムでページを更新すると500エラーが表示されてしまいます。
しかし、更新は完了しており、エラー画面が出てしまう以外は問題なく動いているようです。

エラーログを見てみたところ、
Premature end of script headers:
と表示されており、調べてみるとさくらのレンタルサーバの制約で、666や777のように自分以外に書き込み権限があると500エラーになってしまう、という内容でした。

で、更新されたページを見てみたところ権限が666になっていたので、たぶんこれが原因なのかなーと思ったのですが修正箇所がわからず。。

既に同じ現象に対処したかたがいらっしゃれば、情報を提供して頂きたいです。

すいませんがよろしくおねがいします!

■ BaserCMSのバージョン:1.6.15
■ レンタルサーバー名:さくらのレンタルサーバ プレミアム
■ スマートURLの利用: OFF
■ 設置フォルダ: サブフォルダ
■ 利用しているデータベース: CSV
■ PHPスキル(自己評価):  C
arata > Re: さくらのレンタルサーバ プレミアムでページを更新すると500エラーになる @ 2011/12/26 21:50
こんにちは!koukiさん。

/app/tmp 以下のファイル及びフォルダに対して、705か755の権限を与えてみて貰えますか?丶(・ω・)ノ

■ 不明点解消できるかも。逆引きガイドもあります baserCMS公式wiki
■ Twitter:@arata

kouki > Re: さくらのレンタルサーバ プレミアムでページを更新すると500エラーになる @ 2011/12/27 12:48
回答ありがとうございますー。
chmod -R 755 /app/tmp やってみたのですが、現象変わらずでした。。
ryuring > Re: さくらのレンタルサーバ プレミアムでページを更新すると500エラーになる @ 2011/12/27 20:53
こんばんは。

書込権限を与えている可能性があるフォルダやファイルは次のとおりです。

/.htaccess
/app/config/
/app/config/core.php
/app/config/install.php
/app/db/ を含む配下全て
/app/tmp/ を含む配下全て
/app/webroot/.htaccess
/app/webroot/themed/{テーマフォルダ}/pages/ を含む配下全て

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

kouki > Re: さくらのレンタルサーバ プレミアムでページを更新すると500エラーになる @ 2011/12/28 10:31
返信ありがとうございます!

全部確認してみたのですが、状況かわらずでした。。

どうも、pages/ 配下のファイルが、管理画面から更新すると権限が変わってしまうみたいです(666になってる)
時間あるときに、ページの更新処理見てみます。
ryuring > Re: さくらのレンタルサーバ プレミアムでページを更新すると500エラーになる @ 2012/1/4 11:14
明けましておめでとうございます。

書き込み権限でサーバーエラーとなるところがあるのであれば、仕様を少し検討しないといけないですね。
Apacheの実行ユーザーとファイルの所有者が同じである場合は、書き込み権限の操作をしないなど。

取り急ぎ、ページテンプレートの書き込み権限を与えている箇所は、
/baser/models/page.php の、 525行目あたりです。

そこをコメントアウトしてみてください。

Twitter:@ryuring
baserCMS総合サービスサイト ビーコミ

kouki > Re: さくらのレンタルサーバ プレミアムでページを更新すると500エラーになる @ 2012/1/5 12:53
あけましておめでとうございます。

書き込み権限の件、試してみましたが改善できませんでした。
というか、それが原因であれば、もっといろいろなとこに影響でるはずですよね。。
実行するphpファイルの権限が正しく設定されてれば問題なく動くようです。

どこでエラーになっているかもう少し見てみたところ、
原因は、まったくわからないのですが
pages_controllerのadmin_editメソッドで
$this->Page->save($this->data,false) したあとで
$this->redirect('/admin/pages/edit', $id);
すると500エラー。
saveするまえであれば
$this->redirect('/admin/pages/edit', $id);
しても表示できてました。

また時間取れたら処理を追ってみます。

とりあえず状況の報告まで。
kouki > Re: さくらのレンタルサーバ プレミアムでページを更新すると500エラーになる @ 2012/1/13 0:27
この現象解決してます。共有遅れてすいません。

結局basercms再インストール+mysqlを使用で全部解決しました。

時間あれば原因調べたかったのですがそこまでは至らず。。

さくらのレンタルサーバ使うときは権限の問題もあるし、普通にDB使った方が無難なんですかね。
(ファイルコピーだけでまるっと移せるのが楽そうだなーと思ってcsvで選んだだけので特にこだわりはありませんでした)

構築したサイトはリリースを待つだけの状態なのですが、結構評判いいです。(特に管理画面のみやすさがうけてます)
次回バージョンアップ期待して待ってます!